[Ask] USB to LAN KY-RS9600



  • Hi …
    Im new for using pfsense
    and novice to bsd too
    Like to know isit usb to lan ky-rs9600 is support for pfsense ?

    i have this because my lan card is broken.
    well, it work on xp with they driver provide.

    it look recognize by pfsense
    here short of my dmesg

    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
    sio0: type 8250 or not responding
    sio0: [FILTER]
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ugen0: <vendor 0="" 2="" 0x0fe6="" usb="" network="" controller,="" class="" 0,="" rev="" 1.10="" 1.01,="" addr="">on uhub3</vendor>
    Timecounter "TSC" frequency 1995013296 Hz quality 800
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.

    but i cannt interface assign …
    is it support and can work ...
    or it absolutely wont work ?

    thanks for any reply


    </generic></system>



  • ugen is a "generic USB device" driver. Support for your device is not built into the kernel.

    Have you tried pfSense 2.0 BETA? It is not yet considered ready for production use (its still in testing) but it uses a more up-to-date version of the kernel (including support for more devices) than pfSense 1.x.

    http://www.freebsd.org/releases/8.0R/hardware.html lists the devices supported in FreeBSD 8.0 on which pfSense 2.0 is built.

    http://www.freebsd.org/releases/7.2R/hardware.html lists the devices supported in FreeBSD 7.2 on which pfSense 1.2.3 is built.

    In both cases USB Ethernet devices are listed with other Ethernet devices. Many of the supported USB Ethernet devices are USB 1.x devices and therefore limited to 12Mbps on the USB side. You will have to look further for USB 2.0 devices which are capable of 480Mbps on the USB side and therefore capable of sustaining 100Mbps on the Ethernet. The FreeBSD man pages (at http://www.freebsd.org/cgi/man.cgi) for the particular driver often have details of the maximum USB speed. Take care though, that some devices promote themselves as USB 2.0 devices but are capable of only 12Mbps on the USB side. I have a couple of udav devices which are USB limited to 12Mbps but are capable of 100Mbps on the Ethernet side. These are fine for my ADSL connection which seems to max out at about 4Mbps downstream and 900kBps upstream.



  • im not yet try with pf 2.0
    i should try it in next week …

    in my xp with their driver it run in 10 mbps speed, even in their enclosure support 10/100 mbps
    never mind ...

    ifen "only" running at 10 mbps, thats enough for me, since my adsl conn max to 2 mbps
    i want use on pfsense to connect with as bridge to my adsl modem only

    thanks for reply ...



  • I've picked up udav devices on eBay for a few dollars.



  • @ kakashi …
    @ wallabybob ...

    any result for support that device ...
    i would like to buy too ...

    thank



  • I have bought about 4 USB ethernet devices on Ebay. They all look like the one displayed in http://cgi.ebay.com.au/10-100M-USB-Ethernet-Network-LAN-Adapter-NIC-RJ45-Card-/370379932071?cmd=ViewItem&pt=AU_Networking&hash=item563c5d41a7

    Some worked with pfSense 1.2.3 but they all worked with pfSense 2.0. Under pfSense 2.0 the udav driver attaches to them. The udav driver in pfSense 2.0 has a longer list of devices it recognises.

    Since its rare for the eBay sellers to identify the major chip in the devices they sell its impossible to say with certainty that a particular device will work. But when I made my purchases I could get four for more devices from eBay for less than a brand name device from my local computer shop so I thought I'd take the risk.



  • ugen0: <vendor 0="" 2="" 0x0fe6="" usb="" network="" controller,="" class="" 0,="" rev="" 1.10="" 1.01,="" addr="">on uhub3</vendor>

    I bought 2 of these USB-Ethernet units today for an old laptop that I'm using as a pfsense box. They produced the exact same dmesg output as yours in my pfsense 1.2.3 install. So I booted from 2.0 beta (latest snapshot) and they were detected as 10/100 USB ethernet (ue0 and ue0) devices. However, even though they were detected and had connectivity.. the link was limited to USB 1.0 speed (bout 1-1.5mbps max). They also had somewhat increased latency by 1-5ms when I ran a ping test and were quite unstable.

    I would not recommend using these USB-Ethernet for pfSense. I'm returning them and getting a proper system with Intel NICs tomorrow.


Locked