OpenVPN does not start on boot

  • I have tried several snapshots recently (May 9-16) and for each of them, OpenVPN does not start on (re)boot.

    If it is started manually by re-saving the config, then a link comes up without error.

    Snapshots from the end of April (23-24) did not have this problem.

    Is this related to Bug 449?

    How does one manually start openvpn on the command line in BSD/pfsense?  Or, rather, what is the mechanism for starting openvpn on boot in pfsense?  I get errors like "openvpn does not exist in /etc/rc.d…"


  • Rebel Alliance Developer Netgate

    Yes, it is related to bug #449

    I just go into each of my openvpn client pages and click save and this kickstarts them.

    What type of WAN do you have?

  • The single WAN is static IP, so no complications there.

    The problem is that OpenVPN is my only access to the system.  Clicking "save" after a reboot is not going to be practical.

    It would seem that a simple cron job could mind the link and restart as necessary until a more elegant solution is found.

  • Rebel Alliance Developer Netgate

    Hopefully we can track down and fix the bug so it's a non-issue in the immediate future. :)

  • Certainly a permanent fix is better than a kludge.

    If you give me some hints on where to look, I'll put some effort into tracking down this bug.


  • Rebel Alliance Developer Netgate

    I'm not sure where the problem is at the moment, but there might be some hints in that ticket.

    I'll probably be working on it a little today if I get some time.

  • Rebel Alliance Developer Netgate

    I believe I've found the fix. After you update to the next snapshot, you'll still have to edit/save your OpenVPN tunnels once, but it should be fixed then.

    I might add a bit of upgrade code to fix that for existing 2.0 users.

    EDIT: Maybe no upgrade code, there is no way to tell and old style active (disabled = "") from a new style disabled (disabled = "") except during the actual upgrade process.

  • Sounds good.  I'll grab the next snapshot and give it a try.  I don't have a need for fixing existing installs - it is beta code after all.


  • I've tested the latest snapshot on a VM and a real system and OpenVPN now starts autonomously on reboot.

    Thanks for the quick fix!

Log in to reply