[RESOLVED] - restore not working at all on latest snaps, nanobsd



  • upgraded a while ago to 17th may nanobsd snaps and ended up in a desperate situation, reason being i was having reinstall issues with the vnstat2 package so i decided to reset to factory defaults and restore the config again and thats where it all started, after the reset, i reboot and after that try to restore and pfsense just wont restore nor will it reboot, tried to downgrade to a older snaps few days back and those also wont restore the config, so i downgraded all the way to the 3rd April snaps and tried restoring it there and it restored but just that it didnt reboot automatically so had to do that manually and after reboot i upgraded back to the latest nanobsd snaps and things got back to normal, so i guess restore function definately has issues.

    NOTE: u get a warning in console when i downgraded to 3rd april snaps with the newer config saying the config was created using newer pfsense etc.



  • As far as I know, the restore works but the web GUI freezes and the system does not automatically reboot either.  After the restore finishes, you have to reboot from the serial console or SSH console.  This issue has existed at least for several months, I think.  I first encountered this with the first 2.0 nanobsd snapshot I ever used (back in December).  I'm not sure whether there is a redmine ticket open for this.



  • i have added it to redmine, could u plz brief on how to restore using serial console or SSH etc in such a situation?



  • Do you get the confirmation that it is restoring, but it never reboots?



  • actually the confirmation never comes at all and page status shows as opening and after some timeout value the pages goes done but instead of showing confirmation, in firefox a file download pop up appears and file name as diag_xxx.php , i forgot what was the name in xxx



  • Hmm, I've seen that one before.


  • Rebel Alliance Developer Netgate

    This appears to be an HTTPS issue. It works fine on HTTP but not on HTTPS. In part, anyhow.

    On HTTPS you get a white screen and it halts, on HTTP it says it worked but doesn't reboot.


  • Rebel Alliance Developer Netgate

    After some more research, this appears to be a couple different things.

    The main issue was that the reboot process was spawning a shell to do its job instead of using the internal function. For whatever reason, this was locking PHP even though the same command works fine from the CLI. I fixed this and it works fine now.

    I was getting a blank screen when I submitted a backup at first but now I can't reproduce it. I'm not sure if it has something to do with the size of the backup or what.



  • In my earlier post, I meant to say I haven't seen that before.



  • im using HTTP and for me the confirmation never came using firefox, the page just said loading till the browser reached timeout value or so then that php page download popup came so for me basically nor did it restore nor reboot, might be true that php hangs or so


  • Rebel Alliance Developer Netgate

    The limits on the server are set higher, but it may also be that the config contains RRD data and can be quite large (mine was 4MB)



  • my RRD data i never backup and its disabled so config file is just few KB only.

    try setting web to HTTP, then reset to factory defaults, reboot and then try restoring



  • u can check my config file


  • Rebel Alliance Developer Netgate

    That config is incomplete. Rename it to .txt and attach if you want to put it here.

    It's kind of a moot point though because I made changes to the restore process yesterday, so a test is somewhat meaningless right now unless you're running on the most current code.

    The current snapshot has issues though, wait for the next one.



  • currently on the 17th may

    could u delete it once u have seen it?


  • Rebel Alliance Developer Netgate

    I downloaded it and deleted it.



  • tried it on the 22nd may snap and restore works fine and even reboots fine now, thanks


Locked