Pfsense not downloading packages or snort rules due to DNS (Easy Fix) Plz help



  • Hey guys and gals, running PfSense 1.2.3 and having issues with snort downloading rules, cant add packages etc. The error message im getting is  Unable to communicate to pfSense.com. Please check DNS, default gateway, etc. I can surf the web just fine. On the General Setup page I have the DNS set 4.2.2.2 and 4.2.2.1, as well as the DHCP server page.

    My only issue is that I HAVE to use DNS because I have a few modified cable modems "ahem" ill just leave it at that. I have got this to work in the past, but since I reinstalled pfSense, I cannot get packages to download :(

    Im sure its just something small, ive looked around everywhere. Any advice?


  • Rebel Alliance Developer Netgate

    You will also get that message if something – such as an upstream proxy -- is causing pfSense to not get the data it expects when loading that page.



  • @jimp:

    You will also get that message if something – such as an upstream proxy -- is causing pfSense to not get the data it expects when loading that page.

    Thank you so much for the input, but how would I go about fixing this?


  • Rebel Alliance Developer Netgate

    Well that depends on what is even wrong.

    If you connect a PC there instead of pfSense and try to access http://www.pfsense.com/packages/pkg_config.7.xml  do you get the XML package list, or do you get some other result?

    Also, you may have those DNS servers entered, but you must also uncheck the box which allows the DNS to be overridden.



  • @jimp:

    Well that depends on what is even wrong.

    If you connect a PC there instead of pfSense and try to access http://www.pfsense.com/packages/pkg_config.7.xml  do you get the XML package list, or do you get some other result?

    Also, you may have those DNS servers entered, but you must also uncheck the box which allows the DNS to be overridden.

    The only issue I have is that my cable modem WILL NOT get online without setting a DNS bypass, its modified. Yes I have also checked and unchecked to allow the DNS to be overridden to try and resolve the issue. No luck.

    Thanks for the reply



  • Anyone?


Log in to reply