Squid ERROR: The requested URL could not be retrieved: Operation not permitted



  • I installed pfSense about a month ago and everything has been going good. About two weeks ago I installed Squid, SquidGuard, and lightsquid. I configured Squid as a transparent proxy and enabled blacklist with SquidGuard. Everything has been working smoothly until today. I tried accessing a website to download an update for our system but when I clicked the link to download the .exe file I got the following message:

    ERROR
    The requested URL could not be retrieved

    While trying to retrieve the URL: http://infosource.sagesoftwareonline.com/sw_attach/sso/mas90/serviceupdates/440ProductUpdate.htm

    The following error was encountered:

    * Connection to Failed

    The system returned:

    (1) Operation not permitted

    The remote host or network may be down. Please try the request again.

    Your cache administrator is myemail@myaddress.com.
    Generated Thu, 20 May 2010 16:18:59 GMT by localhost (squid/2.7.STABLE7)

    I can no longer even access the page to the link, I get the same error on multiple clients. I have tried adding the address to the whitelist under the ACL but I still get the same result. I have also added my IP on the LAN to the Bypass proxy list, when I do this the link simply times out. I can access other sites just not this one when I bypass the proxy.

    I'm not sure what can be causing this but I need to be able to allow this site and figure out what is causing this to happen. Can someone please help?



  • I had similar problem with some sites (sorceforge.net was one of them) with the same error.

    The problem was snort and an ET rule.

    Find the IP of that site and search in the blocked (snort) IPs and search for an Alert with the IP in /var/log/snort/alert file.


Log in to reply