Multi WAN + SIP + CISCO GRE



  • Hi,

    Hope you can help me here because I'm running out of options already. I have done everything but still lacking in some areas.

    Here's how my network is setup:

    SITE A SIPX –> PFSENSE --> CISCO -->  |||| VIA GRE TUNNEL  |||| <-- CISCO <-- PFSENSE <-- SIPX SITEB

    I setup multiwan on my pfsense 1.2.3. But have problems getting my sip phones work.

    Voice VLAN 10 -> WAN 1

    • Voice vlan is configured to route traffic thru a GRE tunnel on my Cisco Router.

    Data VLAN 20 -> WAN 2

    • Data vlan is configured without a tunnel.

    Default route is:
    Network: 0.0.0.0/24
    Gateway: 172.16.1.1 (my cisco router LAN interface)

    My NAT rules:
    WAN        172.16.3.0/24       *      *      *      *      *     NO    (VLAN SUBNET) NO NAT IS CHECKED
    WAN        172.16.2.0/24       *      *      *      *      *     NO    (DATA SUBNET)  NO NAT IS CHECKED

    When NO NAT is enabled sip phones to worked just fine (with 2 way comm).

    I tried:
    WAN        172.16.3.0/24      *      *      *      *      *    YES    (VLAN SUBNET)
    WAN        172.16.2.0/24      *      *      *      *      *    YES    (DATA SUBNET)

    But get only one way voice connection.

    FOR MULTIWAN:

    I followed this tutorial http://pfsense.site88.net/multiwan.html which says to add a static route:

    Network: DNS OF ISP 1
    Gateway: 172.16.1.1 (of WAN1 LAN int)

    Network: DNS OF ISP 2
    Gateway: 172.16.2.1 (of WAN2 LAN int)

    Added a Loadbalancing Pool (only fail-over) and create a firewall rule.

    1. My problem is enabling MULTIWAN + FAIL-OVER make my sip phones to get a busy signal. This is not the case without multiwan.
    2. Voice traffic should only be going to WAN1 and stick with it. How can I accomplish this?
    3. I removed the default route but problems still remained and leave the DNS routes but nothing has changed. Still can't get voice to work. What should i do to fix this problem?

    ***VLAN 10 have internet connection and have routing between tunnels. I only had problems with voice when I activated the multiwan. Routing between tunnel are still active.

    ***VLAN 20 is not yet running and should be routed to WAN 2

    Thank you in advance.


Locked