VItelity SIP Trunk to my asterisk server - Not connecting



  • Hi,  I've built several PFSense servers and love it.

    I came across an issue that I cannot seem to resolve with my SIP provider.  I use Vitelity to provide me with a SIP trunk and a phone number.  I had it outside of any firewall just to make the connection which worked great.  After putting it behind PFSense and opened ALL the ports needed for SIP which again I have done for others and they work fine, IP connection does not work.  The only difference from Vitelity to the others is "the Others" connect via a registration unlike Vitelity is looking for a direct IP connection back to their servers.  SO again, I removed PFsense and bingo it worked just fine, added it back and no go.

    Does anyone suggest I create a DMZ using public IP's for the Asteriks server and then with a second NIC leave my other machines behind a NAT with 1:1 with private IPs?

    Thanks in advance,

    -Karim



  • What has worked for me: enable advanced outbound NAT.  click the checkbox for "static port".


Locked