Installation of stunnel-4.25 failed.



  • Hello board,
    i have a problem installing stunnel-4.25 on

    # uname -a
    FreeBSD pfSense.local 8.0-STABLE FreeBSD 8.0-STABLE #1: Wed May 26 23:10:22 EDT 2010     sullrich@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_SMP.8  i386
    
    

    Package Installer Log:

    Downloading package configuration file... done.
    Saving updated package information... overwrite!
    Downloading stunnel and its dependencies... done.
    Checking for successful package installation... of stunnel-4.25 failed!
    
    Installation aborted.
    

    Package appears in the list of installed Packages anyway. Reinstall pkg or xml crashes at:

    Loading package instructions...	Auxiliary files... done.
    	Deinstall commands... 
    
    # cat /tmp/pkg_mgr_stunnel.log
    Beginning package installation.
    Downloading package configuration file...
    stunnel-4.25 Array
    (
        [0] => Requested space: 920 bytes, free space: 2518M bytes in /var/tmp/instmp.BIVIYF
        [1] => tar: Unrecognized archive format
        [2] => tar: +CONTENTS: Not found in archive
        [3] => tar: Error exit delayed from previous errors.
        [4] => pkg_add: tar extract of /tmp/apkg_stunnel-4.25.tbz failed!
        [5] => pkg_add: unable to extract table of contents file from '/tmp/apkg_stunnel-4.25.tbz' - not a package?
        [6] => pkg_add: 1 package addition(s) failed
    )
    
    Package WAS NOT installed properly.
    
    
    # ls -l /tmp/apkg_stunnel-4.25.tbz
    -rw-r--r--  1 root  wheel  230 May 28 11:18 /tmp/apkg_stunnel-4.25.tbz
    # cat /tmp/apkg_stunnel-4.25.tbz
    
    <title>404 Not Found</title>
    
    # Not Found
    
    The requested URL /packages/8/All//stunnel-4.25.tbz was not found on this server.
    
    

    Can someone confirm the broken package?



  • This looks similar to http://redmine.pfsense.org/issues/618.

    If you check http://files.pfsense.org/packages/8/All/ you will find stunnel-4.28_1.tbz, not 4.25 which is what the package config expects.



  • There are indeed parallels in these symptoms.
    Thats's why it's beta (as said in the linked thread inside the bugreport  ;) )
    Just wanted to mention my experience as for example the stunnel package is just listed "?" in the sticky 'packages' topic…

    Thanks so far, i'll install it manually then.


Log in to reply