Setting Proxy Server cache_dir to null breaks proxy server



  • When I set the cache_dir to null in Proxy Server:Cache Management, the proxy server no longer starts. I googled around a bit and found this from the Squid FAQ.
    http://wiki.squid-cache.org/SquidFaq/ConfiguringSquid#Can_I_make_Squid_proxy_only.2C_without_caching_anything.3F

    Can I make Squid proxy only, without caching anything?

    Sure, there are few things you can do.

    You can use the cache access list to make Squid never cache any response:

    cache deny all

    With Squid-2.7, Squid-3.1 and later you can also remove all 'cache_dir' options from your squid.conf to avoid having a cache directory.

    **With Squid-2.4, 2.5, 2.6, and 3.0 you need to use the "null" storage module:

    cache_dir null /tmp**

    It's not big deal–I just set it to a very small cache size--but the null option probably should be there if all it does is break squid :)


  • Rebel Alliance Developer Netgate

    This should be fixed now. I just committed an update to correct the cache_dir line when null is selected. I didn't bump the version number though. Just reinstall the pkg and it should be fine.


Log in to reply