Pfsense new installation: fxp driver dual NIC card massive interrupt load



  • We have a new quad-core xeon HP box for a new pfsense installation.
    (HP ProLiant ML110 G6 Intel X3430 2.40GHz 2GB Memory )
    overkill but cheap ( and nice).

    I was unable to get the mobo NICs to work with the installation so we found an old dual-port Intel NIC and put that in. All worked with fxp drivers, but top showed one proc absolutely slammed with interrupts on the running firewall. Sure enough it was one of the two fxp drivers. The other three procs were nearly 100% idle. Nothing showed up in the logs or unusual in tcpdump.

    So I gave it over to our OS expert and he fixed it this way:

    solution

    He reasoned that the bridge chip on the dual port NIC was confusing the PCI bus. We didn't have another to test, so he turned off APCI in the bios, and edited /boot/loader.conf with this line:
    hint.acpi.0.disabled="1"

    Hope this helps someone else…

    That fixed it, and now all 4 procs are idling along as they should, with basically zero load.



  • I am using the same server to get started with Pfsense. So far I have not been able to get 1.2.3 loaded, it hangs and the keyboard doesn't function.
    I have been able to load the ver 2 June 15 beta but it returns a syntax error when choosing menu items.
    If you could let me know if you had similar issues and what changes you made to get it functioning I would appreciate it.
    Thanks, Mike ???


Locked