Can't get full bandwidth



  • Hi, I'm very new to pfsense, so forgive me if this question has been answered before.

    I have a PF box made out of Pentium 4 2.2Ghz with 512Mb RAM, using pfsense 1.2.3. The box is used as a router and for distributing internet bandwidth fairly to about 30 clients. I have two NICs, one for WAN and another for LAN, both using PCI 10/100Mb card. For internet connection (WAN) I use PPPoE connection with bandwidth of 2Mbps up, and 328kbps down.

    My problem is that when I test my download and upload bandwidth using www.speedtest.net, I manage only to get about 0.12Mbps download speed. I've tried to tweek my traffic shaper, but to no effect. I've already uninstall squid and snort, but I still get the same result. At one point, I also disable traffic shaper and still get the same result.

    Currently I use traffic shaper with the following queue setting:

    Flags Priority Default Bandwidth Name 
                    0    No          342 Kb          qwanRoot     
                    0    No          1800 Kb          qlanRoot     
                    1    Yes              5 %            qwandef     
                    1    Yes            10 %            qlandef     
    ACK          7    No            60 %            qwanacks     
    ACK          7    No            25 %            qlanacks     
    RED ECN    1    No            1 %            qP2PUp     
    RED ECN    1    No            1 %            qP2PDown     
    RED ECN    4    No            25 %            qOthersUpH     
    RED ECN    4    No            60 %            qOthersDownH     
    RED ECN    2    No            1 %            qOthersUpL     
    RED ECN    2    No            1 %            qOthersDownL

    Is this normal or have I screwed up somewhere? Please help.


  • Rebel Alliance Developer Netgate

    If you disabled the shaper and had the same result, it is probably not due to the shaper configuration.

    It may be something with your WAN configuration, perhaps the MTU.



  • jimp, thanks for the reply.

    I have decided to test my pf box at other location with the same PPPoE speed, but have less users behind it (2 users including me!). What I found is that when I do the bandwidth test at this location with www.speedtest.net, my download bandwidth is shown as 1.60Mbps!

    So I guess, my bandwidth is slow before because of heavy usage by users, not because of any settings in pfsense! Silly me….

    I also test my bandwidth (behind pf box that is) for different WAN MTU. pfsense uses 1495 as the default for PPPoE connection. I lowered it down to 1400, and speedtest.net shows 1.2Mbps download bandwidth. Then I changed MTU to 1500, and I get 1.3Mbps. Lastly I changed WAN MTU to 1480, and I get the final result, 1.6Mbps! So I guess, for me MTU 14800 should work fine.

    Now I have to figure out how to block all those P2P file sharing apps (like BitTorrent and Ares). Any thought?



  • Run the traffic shaper and enable the catch all rule and input the lowest kb speed for up and down that you want.


Log in to reply