Traffic shaping issues in router mode (No firewall)



  • I have public ip's for all of my client's so I disabled the firewall under advanced.

    Now when I try to do traffic shaping the wizard runs fine, but when I attempt to check the status of the queues under all I can see is a single queue called "IN".

    Is it possible to do traffic shaping without NAT ?

    Attached is a screenshot of whats in queues.

    I can see in the shaper section all of the queues were created and everything appears to be proper but I cannot use the shaper.

    Any suggestions/ideas/reasons this won't work ?




  • You are confusing two issues, I think.  You can disable NAT in the outbound NAT section for the default rule without turning off the firewall totally (since I believe the pf rules are what steer packets into queues.)  Enable advanced outbound NAT and check the box at the top of the single rule you will then see that says "Enabling this option will disable NAT…"  Give that a try...



  • The easiest way is what the previous message described. Just disable nat and leave the firewall inspection in place and setup rules allowing free flow of traffic. I use several pfsense firewalls this way.


Locked