Pfsense 2.0-Beta problems booting from USB-CDROM



  • Booting the latest snapshot, 6/4/2010, i get the following error on my Atom machine.



  • After mountroot> type
    cd9660:/dev/iso9660/pfSense



  • Since this is a Lanner 7530 with an N270 Atom CPU, it only has USB ports for the keyboard and CDROM so for some reason, i can't type anything into the terminal to try. I tried booting 1.2.3 and earlier versions of 2.0-Alpha and it gives the same error messages. Played with various settings in the Bios and no change. I've concluded that this USB-CDROM does not work well with my atom board even though I have used it in the past to install 1.2.2 on other machines. My next hope is to install the SSD drive into another machine and just install the full version onto it and move the drive back into this machine.



  • Maybe you have a "USB Legacy Keyboard", "USB Legacy devices" or "USB Keyboard" option in your BIOS, enable it and maybe you can type in console with your usb-keyboard.



  • Thanks for the reply. I do believe I have legacy USB enabled already but i'll have to verify when I am at home.



  • I think your plan to install on another machine and move the drive is probably the best strategy, especially if the install machine has an IDE or SATA CDROM drive.

    After moving the drive you will probably need to make a couple of tweaks because the drive will probably change its name when its moved (e.g. /dev/ad0 becomes /dev/ad3).



  • I spent most of my time in the BIOS and with different USB keyboards to figure out why I couldn't type anything during the bootup sequence when the mounting of the root failed. Gave up and finally tried to set the vfs.root.mountfrom=ufs:/dev/ad4s1a from the pc-bootloader shell and it worked!

    I have a nice Lanner 7530 system with a 30GB gen 1 intel SSD and I'm just starting to play with pFsense again!


Locked