Powerd on Atom machine does not seem to be working



  • I enabled powerd on my Lanner 7530 atom machine and it draws 18W from the AC side no mater if i have it enabled or not.

    dev.cpu.0.%desc: ACPI CPU
    dev.cpu.0.%driver: cpu
    dev.cpu.0.%location: handle=\_PR_.P001
    dev.cpu.0.%pnpinfo: _HID=none _UID=0
    dev.cpu.0.%parent: acpi0
    dev.cpu.0.freq: 1596
    dev.cpu.0.freq_levels: 1596/-1 1396/-1 1197/-1 997/-1 798/-1 598/-1 399/-1 199/-1
    dev.cpu.0.cx_supported: C1/0
    dev.cpu.0.cx_lowest: C1
    dev.cpu.0.cx_usage: 100.00% last 500us
    dev.cpu.1.%desc: ACPI CPU
    dev.cpu.1.%driver: cpu
    dev.cpu.1.%location: handle=\_PR_.P002
    dev.cpu.1.%pnpinfo: _HID=none _UID=0
    dev.cpu.1.%parent: acpi0
    dev.cpu.1.cx_supported: C1/0
    dev.cpu.1.cx_lowest: C1
    dev.cpu.1.cx_usage: 100.00% last 500us
    
    

    Any ideas on how I can get some power savings and reduce the heat on the fanless system?


  • Rebel Alliance Developer Netgate

    powerd hasn't seen a lot of testing that I know of. Are you sure that it is running when you have it enabled?

    Can you look in the output of sysctl and see if you have any thermal zones that ACPI can understand on that board? (They'd be under hw.acpi.thermal )



  • When I enable it, I see it running in TOP.

    Here are the hw.acpi sysctls without powered running (if that makes any difference):

    # sysctl hw.acpi
    hw.acpi.supported_sleep_state: S1 S4 S5
    hw.acpi.power_button_state: S5
    hw.acpi.sleep_button_state: S1
    hw.acpi.lid_switch_state: NONE
    hw.acpi.standby_state: S1
    hw.acpi.suspend_state: NONE
    hw.acpi.sleep_delay: 1
    hw.acpi.s4bios: 0
    hw.acpi.verbose: 0
    hw.acpi.disable_on_reboot: 0
    hw.acpi.handle_reboot: 0
    hw.acpi.reset_video: 0
    hw.acpi.cpu.cx_lowest: C1
    
    

  • Rebel Alliance Developer Netgate

    Not sure

    What kind of CPU usage are you seeing on that box?

    powerd's adaptive mode, which pfsense uses, only kicks in if the system is under 50% cpu load, or so the man page implies. I haven't tried to use it on mine so I'm not sure how visible its effects may be. When you run commands it might be driving up the CPU usage and making it shift back up.



  • It is an atom N270 using SMP kernel.



  • Atom processors do not have variable clock speeds - they run at full speed all the time.  As such you can't reduce the power draw.


  • Rebel Alliance Developer Netgate

    @Cry:

    Atom processors do not have variable clock speeds - they run at full speed all the time.  As such you can't reduce the power draw.

    If that were the case, it shouldn't be reporting that it does:

    dev.cpu.0.freq_levels: 1596/-1 1396/-1 1197/-1 997/-1 798/-1 598/-1 399/-1 199/-1

    But it's possible that is the cause.



  • so I ran powerd with -v and it does seem like it is setting the frequencies correctly. I also did a test by setting the cpu.0.frequency manually but the power does not decrease. I think the CPU is throttling and not actually changing the voltage to the CPU. Now, if I can figure that part out…


Locked