Vnstat losing data on restart



  • yeah so like the title says

    for some reason on my pfsense box the vnstat package is losing prior data on a restart

    I tried removing the package and reinstalling but so far no joy

    can anyone give me some advice on how to fix this problem?

    thanx in advance for any assistance.



  • i'm no longer sure it is on restart ….. It seems to be more randomly losing data on one interface or another.    sadly removing the package and reinstalling hasn't solved the issue.

    is there a way i can completely delete all traces of vnstat and then try to reinstall it more cleanly??



  • Afaik it doesn't work on nanobsd.

    If it's on a pc remove the package and delete the content of /var/db/vnstat
    pkg_add -r vnstat for a never version.
    Though somewhat out of date, the links below can guide you to a manual install
    http://forum.pfsense.org/index.php/topic,8460.0.html
    http://forum.pfsense.org/index.php/topic,14179.0.html



  • @Perry:

    Afaik it doesn't work on nanobsd.

    If it's on a pc remove the package and delete the content of /var/db/vnstat
    pkg_add -r vnstat for a never version.
    Though somewhat out of date, the links below can guide you to a manual install
    http://forum.pfsense.org/index.php/topic,8460.0.html
    http://forum.pfsense.org/index.php/topic,14179.0.html

    kewl thank you very much indeed … giving it a try now ...fingers crossed been about 24 hours since deleted package and /var/db/vnstat and tried reinstalling vnstat so far so good.



  • shoot well that didn't work

    try here again

    so more details I was before and am now running pfsense as a virtual machine with vmware server (before with vmware server version 1 now with version 2) I downloaded the vmware appliance and then restored my config to that.

    everything seems to be fine except that vnstat drops all it data for various interfaces every couple days.    Sometimes it will drop the lan data but the OPT1 and WAN data will remain then it will drop the WAN data but the OPT1 and LAN data remains.

    I would really like to get this working as I find vnstat useful for tracking our usage monthly and all.

    anyone got any other ideas?


Log in to reply