"Allow intra-BSS communication" not allowing intra-BSS traffic, bridge issue?



  • This worked on the same hardware before I moved from 1.2.3 to 2.0 BETA, so it's not a question of the hardware not supporting something (ath5212). I have the "Allow intra-BSS communication" box ticked. In spite of this, the laptop in this hand cannot talk to the iPhone in that hand.

    The only interesting thing is the local interface is bridged wireless and wired (as it was before) and I have used the system tunables to force filtering to be on the bridge interface. That said, no filtering is configured.

    arp requests from the laptop for the iPhone are not answered. tcpdump on the iPhone shows the traffic is not getting to the iPhone. If you're using intra-BSS traffic successfully, I'd like to know so I can set about tracking what's afoot here, unless someone has ideas.



  • ifconfig showed ath0_wlan0 "-apbridge"

    interfaces.inc says:
            /* enable apbridge option */
            if(isset($wlcfg['apbridge']['enable'])) {
                    $wlcmd[] = "apbridge";
            } else {
                    $wlcmd[] = "-apbridge";
            }

    and config.xml has:
                                    <apbridge><enable></enable></apbridge>

    so what am I missing?

    ifconfig ath0_wlan0 apbridge
    does fix things and the interface is otherwise correctly configured.



  • applying did not take this setting. a reboot did.


  • Rebel Alliance Developer Netgate

    I opened a ticket for this:
    http://redmine.pfsense.org/issues/657



  • If you change only this setting (either enabling or disabling it), save, and then click apply, does it get applied?  Or do you have to change a combination of settings at the same time for it to not apply properly?


Locked