Nmap package



  • When I try to run nmap -all this occurs. I am wondering if the nmap packages is old or what gives?

    # nmap -all 192.168.153.50
    /libexec/ld-elf.so.1: Shared object "libdnet.so" not found, required by "nmap"
    # pkg_add -vr libdnet                                                         
    looking up ftp.freebsd.org                                                    
    connecting to ftp.freebsd.org:21                                              
    setting passive mode                                                          
    opening data connection                                                       
    initiating transfer
    Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7.2-release/Latest/libdnet.tbz...x +CONTENTS
    x +COMMENT
    x +DESC
    x +MTREE_DIRS
    x man/man3/dnet.3.gz
    x man/man8/dnet.8.gz
    x sbin/dnet
    x bin/dnet-config
    x lib/libdnet
    x lib/libdnet.1
    x lib/libdnet.a
    x lib/libdnet.la
    x lib/libdnet.so
    x lib/libdnet.so.1
    x include/dnet.h
    x include/dnet/addr.h
    x include/dnet/arp.h
    x include/dnet/blob.h
    x include/dnet/eth.h
    x include/dnet/fw.h
    x include/dnet/icmp.h
    x include/dnet/intf.h
    x include/dnet/ip.h
    x include/dnet/ip6.h
    x include/dnet/os.h
    x include/dnet/rand.h
    x include/dnet/route.h
    x include/dnet/tcp.h
    x include/dnet/tun.h
    x include/dnet/udp.h
    tar command returns 0 status
     Done.
    pkg_add: package 'libdnet-1.11_2' or its older version already installed
    pkg_add: 1 package addition(s) failed
    

Locked