IP Changes SLOWLY



  • I am having a strange situation where when I use IP address sites, my IP changes very slowly (on the order of minutes up to maybe 5 minutes, 10 minutes?).. The time is indefinite.

    However, the IP does change eventually.

    It does seem though that the router favors WAN instead of OPT1.

    Thanks for the help…


    Facts:

    1. WAN and OPT1 are Motorola Cable Modems at substantially different bandwidths (~15Mbps WAN, ~79 Mbps OPT1). They use the same ISP, and have the default http://192.168.100.1 access page (so only 1 modem is accessible at a time); despite this, they via DHCP get different gateways.

    WAN Gateway: 69.X.Y.1
    OPT1 Gateway: 68.X.Y.1

    1. Under STATUS->INTERFACE, both interfaces are UP/UP:
      WAN: 6671937/7140771 (1.31 GB/237.57 MB)
      OPT1: 4708516/6987198 (415.16 MB/530.92 MB)
      No dropped or collisions, up or down

    2. Under STATUS->LOAD BALANCING, both interfaces are UP
      WAN: Online Delay: 10.316ms, Loss: 0.0%
      OPT1: Online Delay: 10.842ms, Loss: 0.0%

    We implement 3 cases:
    a- load-balancing
    b- WAN fails; goto OPT1
    c- OPT1 fails; goto WAN

    The polling is done using the GATEWAY IPs of the modems they receive via DHCP.

    –---------------------------------------------------------------------------------
    What I Have Already Tried

    1. I've made sure under FIREWALL->RULES->LAN (tab), we have:

    (There is a "special case HTTPS" that comes first….)

    Proto Source Port Destination Port Gateway Schedule Description

    • LAN net * * * WanBalanceOpt   Load Balancing (EXEC LAST)
    1. Under FIREWALL->NAT->OUTBOUND, we have:

    SELECTED: Manual Outbound NAT Rule Generation

    We created a rule for each cable modem:

    WAN  10.0.0.0/24 * * * * *
    YES
    Auto created rule for LAN

    OPT1  10.0.0.0/24 * * * * *
    YES
    Auto created rule for LAN

    1. Under SYSTEM->ADVANCED:

    SELECTED: Sticky Connections



  • It appears the reason is because I have STICKY CONNECTIONS ENABLED

    DO NOT ENABLE STICKY CONNECTIONS FOR MULTIWAN
    I thought the "do not use" restriction has been lifted lol.


Locked