Computer Hangs at Computer Splash Screen



  • When I finished the setup and rebooted the computer it hung at the computer splash screen. Another words it will not post. When I unplug the hard drive it will go ahead and run past the splash screen and finish the post giving me a warning that there is no hard drive. Has anyone ever encountered this problem.

    Thanks for your help!



  • Concidering that pfSense isn't even loaded yet I would say this problem is related either to a faulty HDD or maybe the controller.

    The fact that you got it installed though is quite interesting, which would lead me to believe the fault is intermittent.

    (When you say computer splash screen I assume you mean the full screen banner that some BIOS' have instead of the regular POST-screen).



  • I, like many other computer geeks, have encountered this problem many times. Its hard to say what is at fault, but you can start to eliminate components to get down to the issue.

    Remove all cards that you don't need like nics, modems, etc.
    Remove all usb devices. Disconnect power from CD-ROM, HDD, etc.

    Now reset BIOS to default settings. See if the system will successfully post with nothing attached (with video of course and RAM)

    You can then start to add things back and find the issue. Start with the HDD. If it posts, then move on.

    My initial suspicion is the HDD. Remove and replace. Re-install and see if you can successfully post after that.



  • I tried two hard drives and got the same results. The video card, network card and sound card are all onboard so I can't remove them. When I remove the hard drive it will go ahead and post. I tried a hard drive that was used and then one that was brand new out of the package with the same result. Does it matter if the drives are EIDE or SATA?  I am wondering if it is a Computer hardware issue. Something must not be compatible with BSD. By the way the computer is a Gateway 4200 series with 512mb Crucial ram. Anymore thoughts would be greatly appreciated.



  • I'm taking a wild guess that it might be a issue with your controller.

    This is typical behaviour on faulty hardware, and has nothing at all to do with the OS (concidering this is way before a bootloader is even detected).


  • Rebel Alliance Developer Netgate

    This kind of thing can happen just as easily with a bad cable as a bad drive. If it's EIDE, make sure you're using a good 80-conductor cable, and that you have it plugged in properly (blue end in the motherboard). If it's SATA, swap the cable out for another one or try a different SATA port.

    I've also seen it happen when a drive was plugged in but not powered properly, so try switching to a different power connector as well.



  • @jimp:

    try switching to a different power connector as well.

    Or even a different power supply if your don't have means of verifying power is good when the disk is spinning up.



  • If the drives are SATA put the controller into legacy mode.



  • @tommyboy180:

    If the drives are SATA put the controller into legacy mode.

    Depending on the BIOS and controller this is sometimes called IDE mode (or the other mode avaliable that is not AHCI).


Log in to reply