Alix 2d3 + Pfsense nano 1.2.3 +broadcom minipci card no driver?



  • Hello

    I have an Alix 2d3 board 0.99h bios and i tried to put a broadcom 4311 minipci card inside.
    It seems that pfsense does not recognize this card because it does not appear on interfaces section.
    From status.php page i found this line:

    pci0: <network>at device 12.0 (no driver attached)

    So i tried Pfsense 2.0 alpha and this time pfsense recognized the card but with no carrier status.
    After some search i found that it needs some kind of firmware to be loaded on pfsense.

    My question is:

    1. Is there any chance to make this card work on pfsense 1.2.3 loading a different version of FreeBSD and the missing firmware? version 2.0 alpha is not an option…</network>



  • Given that you have said pfSense 2.0 ALPHA (did you mean BETA) is not an option for you I suggest it will be less effort to replace the Broadcom mini PCI card by a mini PCI card based on the Atheros chipset or Ralink chipset that are supported by FreeBSD. If I recal correctly, I have seen mini PCI cards based on these chipsets available quite cheaply on eBay.


  • Rebel Alliance Developer Netgate

    There is probably no way to make that card work on pfSense 1.2.3.

    pfSense 2.0 is at BETA3 now, it is no longer Alpha, and it's actually fairly stable in many regards (but still needs work in others). Make sure you are using a current snapshot from the last couple days and it should be OK for many things.


Log in to reply