Squid 2.7.9 Delay pool not working?(traffic mgmt)



  • delay pool supposed to be fixed with 2.7.9 version but is not working for me?

    anyone can help me?

    Version  1.2.3-RELEASE
    built on Sun Dec 6 23:38:21 EST 2009
    FreeBSD 7.2-RELEASE-p5 i386
    +
    squid 2.7.9 transparent + squidguard 1.3-2 + Traffic shapper.

    squid -v                                                              
    Squid Cache: Version 2.7.STABLE9
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--da
    tadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstat
    edir=/var/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=
    lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll'
    '--enable-auth=basic digest negotiate ntlm' '--enable-basic-auth-helpers=DB NCS
    A PAM MSNT SMB LDAP SASL YP' '--enable-digest-auth-helpers=password ldap' '--ena
    ble-external-acl-helpers=ip_user session unix_group wbinfo_group ldap_group' '--
    enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth'
    '--with-pthreads' '--enable-storeio=ufs diskd null aufs coss' '--enable-delay-po
    ols' '--enable-snmp' '--enable-htcp' '--enable-forw-via-db' '--enable-cache-dige
    sts' '--enable-referer-log' '--enable-arp-acl' '--enable-pf-transparent' '--enab
    le-follow-x-forwarded-for' '--with-large-files' '--enable-large-cache-files' '--
    enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch
    English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese
    Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbi
    an Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish Ukrainia
    n-1251  Ukrainian-koi8-u Ukrainian-utf8' '--enable-default-err-language=English'
    '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '-
    -build=i386-portbld-freebsd7.2' 'build_alias=i386-portbld-freebsd7.2' 'CC=cc' 'C
    FLAGS=-O2 -fno-strict-aliasing -pipe -I/usr/local/include -I/usr/local/include
    -DLDAP_DEPRECATED' 'LDFLAGS= -L/usr/local/lib -L/usr/local/lib' 'CPPFLAGS=-I/usr
    /local/include'


  • Rebel Alliance Developer Netgate

    We need a lot more information than "it doesn't work" specifically what you set, what you tried, and how you confirmed the results.



  • Hi Jimp,

    Thanks to answer me.

    My settings are

    squid 2.7.9 transparent + squid-guard 1.3-2 + Traffic shapper

    Squid Traffic Management setting:

    Maximum download size: 10000
    Maximum upload size: 10000
    Overall bandwidth throttling: 400
    Per-host throttling: 200

    and all download getting the full speed, I've tried if I specified the proxy in browser setting, getting full speed too.
    Try to download file.exe from a website.

    Thanks



  • need more info?



  • Squid 2.7.2, 2.7.8, or 2.7.9  does not support delay-pools.
    The problem would be finished if we substitute the squid with "lusca-head" ..
    ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/lusca-head.tbz

    squid -v

    Squid Cache: Version LUSCA_HEAD
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/usr/local/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--disable-unlinkd' '--with-pthreads' '--enable-storeio=aufs coss' '--enable-delay-pools' '--enable-snmp' '--disable-carp' '--enable-htcp' '--disable-wccp' '--disable-ident-lookups' '--enable-arp-acl' '--enable-pf-transparent' '--with-large-files' '--enable-large-cache-files' '--enable-err-languages=English' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=i386-portbld-freebsd8.0' 'build_alias=i386-portbld-freebsd8.0' 'CC=cc' 'CFLAGS=-O2 -pipe  -fno-strict-aliasing' 'LDFLAGS=' 'CPPFLAGS='



  • hmm

    read this is supposed to be compiled with delay on the 2.7.9 version

    http://redmine.pfsense.org/issues/688#change-2288


  • Rebel Alliance Developer Netgate

    @anto_DIGIT:

    Squid 2.7.2, 2.7.8, or 2.7.9  does not support delay-pools.
    The problem would be finished if we substitute the squid with "lusca-head" ..
    ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/lusca-head.tbz

    squid -v

    Squid Cache: Version LUSCA_HEAD
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/usr/local/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--disable-unlinkd' '--with-pthreads' '--enable-storeio=aufs coss' '--enable-delay-pools' '--enable-snmp' '--disable-carp' '--enable-htcp' '--disable-wccp' '--disable-ident-lookups' '--enable-arp-acl' '--enable-pf-transparent' '--with-large-files' '--enable-large-cache-files' '--enable-err-languages=English' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=i386-portbld-freebsd8.0' 'build_alias=i386-portbld-freebsd8.0' 'CC=cc' 'CFLAGS=-O2 -pipe  -fno-strict-aliasing' 'LDFLAGS=' 'CPPFLAGS='

    Delay pool support is compiled into 2.7.9. I know. I compiled it myself, and it reports that it does so in the version string:

    squid -v

    Squid Cache: Version 2.7.STABLE9
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/var/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--enable-auth=basic digest negotiate ntlm' '--enable-basic-auth-helpers=DB NCSA PAM MSNT SMB LDAP SASL YP' '--enable-digest-auth-helpers=password ldap' '--enable-external-acl-helpers=ip_user session unix_group wbinfo_group ldap_group' '--enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--with-pthreads' '--enable-storeio=ufs diskd null aufs coss' '–enable-delay-pools' '–enable-snmp' '--enable-htcp' '--enable-forw-via-db' '--enable-cache-digests' '--enable-referer-log' '--enable-arp-acl' '--enable-pf-transparent' '--enable-follow-x-forwarded-for' '--with-large-files' '--enable-large-cache-files' '--enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbian Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish Ukrainian-1251  Ukrainian-koi8-u Ukrainian-utf8' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=i386-portbld-freebsd7.2' 'build_alias=i386-portbld-freebsd7.2' 'CC=cc' 'CFLAGS=-O2 -fno-strict-aliasing -pipe -I/usr/local/include -I/usr/local/include  -DLDAP_DEPRECATED' 'LDFLAGS= -L/usr/local/lib -L/usr/local/lib' 'CPPFLAGS=-I/usr/local/include'

    If there is a problem in the package code that makes the config file, that is another question.

    If the maker of the Lusca package would provide us with patches to add their package to the official repo, it would likely be accepted, as long as it was separate and didn't replace the existing squid package.


Log in to reply