Involuntary/inadvertent WOL



  • I have a client on the LAN with BIOS set to wake-on-lan (WOL) and have noticed sometimes when I shut the machine down for the night and leave for the day, that when I return it will be booted without me having sent a WOL packet through the webGUI or any other means. In fact, the machine in question will be booted even if there are no other clients active on the LAN. Has anyone heard of this? Is this perhaps a local BIOS/hardware issue? I should also mention I've never noticed this problem before using pfsense, but then again have never enabled WOL (through an on-chip LAN adapter, not PCI) on the machine in question.



  • Check if other wake up events are enabled. It might be triggered by something else. This is definately not a pfSense related issue. The pfSense doesn't send random WOLs  ;)



  • I figured this wasn't a pfsense issue but at least wanted to get a confirmation on this.

    Check if other wake up events are enabled.

    You mean check for other wake-up events in the BIOS, correct?



  • Pull the network cable from it and see if it still wakes up. If so then theres something else set in the bios. Some have settings to have machines turn on at certain times, etc.



  • @chipzoller:

    I figured this wasn't a pfsense issue but at least wanted to get a confirmation on this.

    Check if other wake up events are enabled.

    You mean check for other wake-up events in the BIOS, correct?

    Yes, check the bios of the machine that has the insomnia  ;D



  • The BIOS option is fine, but strangely, if I have the option enabled and then either plug or unplug the machine from the switch/WAP that I'm using (when the machine is turned off) then the machine will boot. I think it's just this crappy Soyo MB that's in it.



  • For 3Com NIC's there a small utility that lets you specify different kinds wakup events for the NIC, for example: magic packet, arp, ping AND change of link state.
    Don't know what kind of NIC you are using, but it sounds like change of link state is activated on your NIC.
    Look around and see if you can find some utility to konfigure NIC, so that it only wakes up on a magic packet. That might solve your problem.



  • Update:  It turns out that after I updated my onboard NIC drivers to the most current version this version allows you to set the wake-up type (after enabling WOL in APM for the NIC, which is also a setting through this driver) to several different things, one of which was magic packet. Now all is well. Thanks fly out to squarepusher for putting me on to the idea of multiple events triggering a WOL scenario.

    I bet this $280 NIC will WOL and then some more…and for that much it better wake me from bed, too.

    http://killernic.com/KillerNic/


Log in to reply