Squid -> howto redirect traffic to opt1 instead of wan?



  • Hello,

    this is my first machine with pfsense (1.2.3), I got experience with IPCop, but the cop can't handle multiple WAN interfaces.
    I use the following setup

    -> WAN1 (SDSL 2MBit/s line with 5 IPs)
    LAN -> pfsense -|
                            -> OPT1 (ADSL 16 MBit line)

    I use the WAN1 interface for our exchange server exclusive and for all FTP/SSH connections from the LAN interface. All other traffic is routed to OPT1

    This works very well.

    Now I want to use the squid package, installed, configured as intransparent (at the beginning). When I use Firefox with proxy settings pointing to the squid all squid traffic is routet to WAN1.
    Why is pfsense routing this way?

    I attached the firewall LAN rules.

    IP information: pfsense = 192.168.2.198, exchange = 192.168.2.5, LAN= 192.168.2.0/24, WAN1 = 85.182.xx.xxx/29, OPT1 => ADSL Router with 192.168.1.1 giving 192.168.1.20 as DHCP to OPT1 interface



Log in to reply