How do I install a git package and rt2860 driver on pfSense 2.0/FreeBSD 8.1-R1?



  • Hey Guys,

    I need a little bit help.

    For my WLAN/WiFi card need I this driver:
    http://repo.or.cz/w/ralink_drivers.git

    But git is not installed in pfSense.
    How do I install a git package on pfSense 2.0-BETA3 / FreeBSD 8.1-R1? I want install this driver. Or I have another option to install this driver?

    Thanks for your help.


  • Rebel Alliance Developer Netgate

    That is a source code repository, and would need to be compiled. You need to download that on a full FreeBSD installation and compile it there, then move the resulting file (probably a KLD, <something>.ko) to pfSense in /boot/modules/

    (And you are referring to pfSense 2.0, which is based on FreeBSD 8.1-RC1, it is not pfSense 8.1-R1)</something>



  • Ok, here's the status: I'm working on it. But is not that easy …

    Right, I meant pfSense 2.0 BETA-3 and FreeBSD 8.1R1.  ;)

    I write when I was not progressing. Thanks.



  • Ok, I get it.
    Module rt2860.ko is now in /boot/modules
    permissions: 644

    I restarted the computer.
    But the module was not loaded. I could nothing find in dmesg.
    I just load it manually, with:
    kldload -v /boot/modules/rt2860.ko

    Can it be started automatically at system startup?
    Whether the modules work, I test yet.
    Thanks

    dmesg
    EDIT:

    
    rt28600: <ralink rt2860="" pci="">mem 0xfe9d0000-0xfe9dffff irq 21 at device 1.0 on pci1
    rt28600: invalid EEPROM powersave level
    rt28600: MAC/BBP RT2860 (rev 0x28600103), RF RT2850
    rt28600: skip channel 10, could not find extension channel
    rt28600: skip channel 11, could not find extension channel
    rt28600: skip channel 12, could not find extension channel
    rt28600: skip channel 13, could not find extension channel
    rt28600: skip channel 14, could not find extension channel
    rt28600: skip channel 64, could not find extension channel
    rt28600: skip channel 140, could not find extension channel
    rt28600: skip channel 165, could not find extension channel
    rt28600: [ITHREAD]</ralink> 
    

  • Rebel Alliance Developer Netgate

    You can load a module automatically by putting:

    module_load="YES" in /boot/loader.conf or /loader.conf.local

    So you should be able to put:

    rt2860_load="YES" and it should work.


  • Rebel Alliance Developer Netgate

    You may also have to edit /etc/inc/globals.inc and add that card type to the wireless_regex variable.



  • Hello ..

    I edit /etc/inc/globals.inc:
    default value:
    "wireless_regex" => "/^(ndis|wi|ath|an|ral|ural|iwi|wlan|rum|zyd|mwl|bwi|ipw|iwn|malo|uath|upgt|urtw|wpi)/",

    and now:
    "wireless_regex" => "/^(ndis|wi|ath|an|ral|ural|iwi|wlan|rum|zyd|mwl|bwi|ipw|iwn|malo|uath|upgt|urtw|wpi|rt2860)/",

    Thats right?
    Thanks for your help.


  • Rebel Alliance Developer Netgate

    That looks right. I'm just not sure if that driver name ending in a number will cause it problems. Whoever wrote that driver did a very poor job of naming its devices.



  • Ok.

    I made the latest update, but all the manual changes were lost.

    /etc/inc/globals.inc:
    "wireless_regex" => "/^(ndis|wi|ath|an|ral|ural|iwi|wlan|rum|zyd|mwl|bwi|ipw|iwn|malo|uath|upgt|urtw|wpi**|rt2860**)/",

    /boot/loader.conf
    rt2860_load="YES"

    So I had to load the kernel manual again:
    kldload -v /boot/modules/rt2860.ko

    Will this be for every update? Also in the stable version? If that only in the beta, it's ok for me.

    But after the update I have not fixed my real problem:
    "Potential DNS Rebind attack detected, see http://en.wikipedia.org/wiki/DNS_rebinding"
    (https connection over the LAN!)

    Must I wait for the next update, to solve the problem? Because, that here I do not unterstand:
    http://forum.pfsense.org/index.php/topic,26434.msg137878.html

    I waited three updates and the problem it's the same. I want to test my card correctly, but unfortunately I can't do without the web interface.
    If you could help me I'd be very grateful.
    Thanks.


  • Rebel Alliance Developer Netgate

    Yes, those files are reset on every update.

    Try /boot/loader.conf.local - I think it's left alone on update, but globals.inc will be replaced on every update.

    As for the rebind error, it should be fixed in the current snapshot. Several of us were working on most of its issues last night, and it worked fine in almost every scenario now. If it doesn't work for you, we'll need a lot more detail (in that other thread) about exactly how you are accessing the webgui (by IP, by name, advanced webgui settings, etc, etc)



  • Ok, I create this file because it does not exist.
    /boot/loader.conf.local

    rebind error:
    I wrote on the explain what I have done, than it turned out that a new update is available. At the time of the last post, this update was not available. This problem is now resolved. Many thanks!

    Now I can test the driver properly. Thanks.



  • Hello.

    I got the following error:
    php: /interfaces.php: pfSense is restoring the configuration /cf/conf/backup/config-1278547486.xml

    when I used the following PSK:
    .1hnan7Q1Cyf.nxLm88sFMoOG6g§F524YX+rDyqj2j1mj+,W0QPfx:ce(\7$hSq

    I don't know if this is for you of interest.  ???
    I chose now a other PSK.

    EDIT:
    RTT value on the widget "Gateways":
    -13588966995985152843827968944139782351961802267074805204526830071317356392587174481194185501097739377971412818666246158998451847267062673315825636077790379657220981402364191638545629194410851107359058421964321980395821770126880749014354801503240192.000ms
    A little too long the number.

    And a other error:

    It's just when I'm in the menu Wireless.
    Wireless works, unfortunately, still not with this driver.
    Status: no carrier
    Do you have a tip for me? :'(


  • Rebel Alliance Developer Netgate

    The PSK error is likely because you have some characters in there that are breaking the XML validation (I'm guessing it's at least the §). I'm not even sure that's valid in a PSK on other devices.

    The RTT on the widget is a known bug with apinger. Someone is working on that.

    As for the other issues, I do suspect you're having problems because of the device name. All other network cards only end in a number that is their device number, and don't have a number as part of the actual device name. I believe some parts of the code rely on this fact, and it's not trivial to work around.

    If there is a way to change the code to fix the device name, even to just "rt" so devices are "rt0" and so on, I bet it would start to work. (I don't see that rt is in use)



  • Just wondering if there's been any progress on this issue.  I have the same pci card/chipset.  Would love to get it working.



  • Any news? can someone post a binary file?


Log in to reply