[solved] NAT problems when CP enabled



  • Hi @ll

    Seems there is a problem with NAT when the Captive Portal is enabled, is there any solution
    in sight for this problem ?

    cheers ;-)


  • Rebel Alliance Developer Netgate

    There is no problem in a normal configuration.

    We'd need a lot more information about what exactly the problem is, and perhaps a copy of your configuration with passwords removed, in order to help.



  • Of course jimp but I had a some post here regarding this one http://forum.pfsense.org/index.php/topic,23655.0.html
    and the help of the people here was great but whatever I did I could not get NAT working.
    From my experience NAT stops working as soon as I enable the Captive Portal which is the excellent feature of this
    Distro I need urgently because we are providing wireless access for the guest in a Hotel with it.
    It is a network with some 40 access points and in oder to monitor them I have a Ubuntu box running Zenoss and
    als a NoMachine for Linux Server for comfortable desktop access listening on Port 22. This is the box and the
    Port I need NAT for.

    I have built let's say 7 or 8 different test boxes and it was the same on all of them, the problem was reproducable
    throughout.

    I mean I really appreciate the brilliant work the guys here are providing and the box (without NAT) is working
    execellent…



  • On the captive portal allowed IP addresses, try adding an entry to allow to that server's IP address.



  • Thanks, but this did not work too. you know I cannot understand this as I can see packets on Port 22
    going through the Firewall to the management host


  • Rebel Alliance Developer Netgate

    So you're talking about a port forward? You need to be more specific than "NAT" because "NAT" covers a lot of things, usually when you say "NAT" on its own, it means outbound NAT.

    Add the IP of the port forward target in the Captive Portal IP bypass twice, once for 'from', and once for 'to'.



  • jimp you're the man, it works  ;D But what I do not understand is that I have had this working in my early attemts with PFsense
    and never used this CP allowed IP adresses feature. For my installation it just stopped working suddenly.
    Maybe it would be a good idea to add this helpful hint to the guides.
    Thank you very much

    thafener


  • Rebel Alliance Developer Netgate

    That's easily explained, you probably authenticated with the portal from the system that is acting as the server. Once it's authenticated through the portal, it will work for a while. It's session eventually timed out, and its access was blocked at that point.



  • Well I have added the MAC of the management box to the list of pass-through MAC's and
    I thought this would be enough but it seems it was not  ;)



  • Hi,

    I had the same problems, but I solved it with adding the MAC to 'Pass throught MAC' and also the IP address to 'allowed IP addresses' for the Server which should reachable.
    CP is not disabled and everything is working flawless!

    Cheers


Log in to reply