DHCP-Server, gateway issue and backup/restore-problem



  • I did an upgrade from 1.2.3 to the snap of yesterday, which resulted in a complete inoperable box. :(
    So i decided to install from scratch, which worked.
    But when i tried to restore my previous saved 1.2.3 config i got the same as before: a dead box. Only new install revived it.

    ok, so i installed newly and tried to restore step by step.
    Restoring aliases worked fine, but all other restores resulted in - nothing!
    I got messages from my browser stating a broken connection, a reload reloaded the backup/restore-page with nothing done. No setting restored. :(
    Again trying to restore the complete config: had to do a new install.

    Next big issue is that no DHCP-lease on lan is showed in Status - DHCP-leases. So i'm not even able to see any of the connected PCs nor add them to static entries. Very weird.
    I did an update today with no change.

    When i put in a static entry even arp-table shows nothing more. Before i could see my connected PCs, but after entering the first static mapping it was gone.

    Looking at my gateways tells me: nothing. The dashboard-widget is empty. At System -routing i had to edit and make wan default gateway, but afterwards the widget still shows nothing. Status - Gatewasy is empty too.

    Is there anything i could do wrong here? Internet-connection works, Diagnostic - Routing tables shows there IS a gateway entry.



  • Please email me the configuration that simply restoring leaves with a broken system.  cmb at pfsense dot org  with a link to this thread.


  • Rebel Alliance Developer Netgate

    I sent you this via e-mail, but I figured I'd update the thread so others would know:

    Somehow you had an invalid/incompete (but disabled) config for RFC 2136 Dynamic DNS updates. The upgrade code for that was apparently very broken, and it caused the config upgrade to bomb/fail.

    I fixed the upgrade code and on a test VM your config upgrades properly now.

    Wait for the next snapshot or two and then give it another try.


Log in to reply