Dd in debian no good for pfsense



  • Hello

    I am just testing pfsense, after successfully working with monowall… weird thing is that I cannot see a way how to make a successful copy to a 1gb CF from the mirrors... it doesn't boot AT ALL.
    The CF "works" with Monowall..., so why it is not booting pfsense, what is SO different in the boot sector or whatever... as if it is no mbr, fat, whatever... just a nice black screen with cursor-
    i downloaded it several times... tried the 512 image, nothing-
    i tried what was suggested in the monowall web, cause, weird enough again... there was no indication for linuxusers how to do it...
    something like this i tried, since this worked for the little monowall image in their web:
    gunzip -c generic-pc-xxx.img | dd of=/dev/hdX bs=16k
    I inflated the gzip image and just made the dd... it didn't work.
    but what should be the right command if not this...
    no tutorial... not just a single line command on the web. on the wiki, nothing...
    I don't want to reinstall windows... please, that's the reason I am "upgrading" that machine to pfsense.
    This is an old mini-itx mainboard, and pata cdrom is broken... no sata connection... so no cdrom solution for me...
    no usb boot solution for me either... it doesn't boot from usb...
    no network pxe solution i found...
    I tried an usb with puppy linux... then tried to do the dd thingy to the cf... nothing...
    Can anybody help me?



  • You don't say HOW your CF was connected to the debian system: through a CF to IDE adapter? through a USB card reader? This makes a difference (or used to make a difference) to the device name on a Linux system - (hdX for connection through a hard disk controller, sdX through a USB card reader).

    I also suspect you shouldn't be unzipping a .img file - the .img suggests its not compressed. A gzip compressed file will normally end in .gz.

    Basically your idea is correct - you should be using dd to write a disk image to the whole CF and its name will be hda or hdb or … or sda or sdb or ... NOT something like hda3 (which is a disk partition, not which the whole "disk").



  • I tried with a USB CF reader… also sdb
    THEN, with a puppy linux USB on target PC, I tried directly the dd to hda connected to an CF / harddrive adaptor...
    don't suspect hardware... puppy linux was able to mount hda... and CF is bootable!
    when dding to CFreader with the monowall image, CF booted up when as hda. Just this alone would show that I knew what hda vs hdax means.
    It's a 4-5 years old Epia M10000 mini-itx... it boots on USBhd (as with puppy linux)
    tried compressed/uncompressed method... no boot. blinking cursor.



  • You are aware the embedded version of pfSense uses the first serial port as the console? I don't run the embedded version myself but from what I have read I would expect the embedded version to output to the video adapter something between nothing and very little when it boots; something between most and all of the action happens on the serial port.

    I'm speaking only for myself here. I know the difference between hda and hdaX but that doesn't mean I always type the correct one for the context.



  • Hello,
    I've just finish to copy an img to a CF (from Debian) no problems…

    dd if=pfSense-1.2.3-RELEASE-4g-nanobsd.img of=/dev/sdg 
    
    7827687+0 enregistrements lus
    7827687+0 enregistrements écrits
    4007775744 octets (4,0 GB) copiés, 3947,2 s, 1,0 MB/s
    
    

Log in to reply