Intel NIC I340-T4 (82580 chipset) not recognized, how to make it work?



  • This is Intel's latest generation NIC family. Haven't found any
    support for this in the FreeBSD hardware list (or FreeBSD 8.0
    for that matter) as of yet.

    Intel provides a FreeBSD driver here:
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=15815&ProdId=3248&lang=eng

    However I have no way to compile this on pfSense (no toolchain).
    And I also wonder if I do compile it as a loadable module, will it
    conflict with pfSense's igb module (I could install bsd somewhere
    and try the compile).

    I assume it will be supported eventually but would be great to know
    the timeframe if there is one.

    Thanks in advance for any suggestions/ideas!

    –Ed



  • Native support will only come when support for it is included in FreeBSD.  As such there's no way for the pfSense developers to guess when it'll happen.

    If you want native support you'll need to raise the issue with the FreeBSD developers and possibly work with them to have it supported (including donating one to a developer).


  • Rebel Alliance Developer Netgate

    Have you tried a 2.0 snapshot? It may just be that the documentation isn't current.



  • Compiling the Intel provided module elsewhere and installing to pfSense worked!

    1 - Installed FreeBSD 7.2 on a separate machine
    2 - Downloaded driver from http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=15815
    3 - Compiled module per Intel instructions
    4 - Copied the compiled if_igb.ko to a flash drive
    5 - Inserted flash drive to pfSense box and mounted with
          # mount_msdosfs /dev/da0s1 /mnt
    6 - Copied module from flash drive to pfSense directory:
          /boot/kernel/
    7 - Modified /boot/loader.conf file to add:
          if_igb_load="YES"
    8 - Rebooted pfSense server
    9 - Made changes to pfSense interfaces assignments
    10 - Rebooted pfSense server
    11 - Works fine!

    Thanks to the folks who replied - I did not try pfSense 2.0 beta as we're
    in production and 2.0 beta is not being recommended for production.

    –Ed



  • glad to see you got it working



  • The ports on this card do not get seen as being VLAN compatible by pfSense. I assume the hardware can do it, since this is Intel's latest ethernet chipset for server use. Not sure if the problem is with the driver provided by Intel, with FreeBSD or with pfSense itself.

    On another note, I checked http://www.freebsd.org/releases/8.1R/hardware.html and this chipset is still not being supported out of the box.


Log in to reply