WebGUI - HTTPS - WebGUI redirect - Not working as expected



  • While working with the WebGUI config (seeing if I can run both secure and non secure sites to host proxy file)  I discovered that when protocol is set to HTTPS and the check box is set to UNCHECKED for "WebGUI redirect" "Disable webConfigurator redirect rule" redirection still occurs.

    HTTPS and WebGUI redirect selected
    or
    HTTPS and WebGUI redirect NOT selected (unchecked)
    Produces the same result in lighty-webConfigurator.conf

    
    ## ssl configuration
    ssl.engine = "enable"
    ssl.pemfile = "/var/etc/cert.pem"
    
    $SERVER["socket"] == ":80" {
    	$HTTP["host"] =~ "(.*)" {
    		url.redirect = ( "^/(.*)" => "https://%1/$1" )
    	}
    }
    
    


  • Fixed, thanks.



  • When was this fixed and how?  I am still seeing this same behavior using the 2.0 RC



  • So I just figured it out.  On the NAT rule I had to enable NAT reflection (the default setting is off).


Locked