FreeSWITCH… incoming / outgoing calls



  • Recently got a FitPC2i box and decided to put pfSense 1.2.3 on it.  Loving it.  Yesterday, my Trixbox CE box died with a HD crash so I decided to add the FreeSWITCH package and migrate to it… unfortunately... I'm getting my butt kicked by this.

    Here are some questions to get started.

    1. I setup two extensions and could not get them to connect to the LAN interface.  Eventually I tried the WAN interface and that worked.  I would assume that I want my internal phones to connect to the LAN and not the WAN interface.  Any thoughts on why this would be happening?

    2. I setup two gateways (Flowroute.com and Vitelity) and those register fine, but I can not get a call to come thru.  I assume the PUBLIC section which has a rule for inbound (condition  destination_number  ^(phone#)$) etc is what I needed.  Is there suppose to be rules in the firewall for inbound calls?  My thought was since FreeSWITCH is listen on the WAN port, that wouldn't be necessary.

    3. Finally, can't do outbound calls either but my bigger concern is on incoming for now.

    Any pointers on what I'm doing wrong.

    Thanks!



  • Have you followed the instructions located at http://doc.pfsense.org/index.php/FreeSWITCH ?



  • Sorry for the late reply been working making FusionPBX easier to use. Also recently added Time conditions (time based routing), Queues, and interactive Queue list for active and recently active Queues.

    1. I setup two extensions and could not get them to connect to the LAN interface.  Eventually I tried the WAN interface and that worked.  I would assume that I want my internal phones to connect to the LAN and not the WAN interface.  Any thoughts on why this would be happening?

    By default the internal profile binds to the WAN IP. The internal profile handles SIP on 5060 TCP or UDP.
    You can change the internal sip profile sip-ip and rtp-ip and set it to the LAN interface IP address. Leave the external profile registering on the WAN interface.

    1. I setup two gateways (Flowroute.com and Vitelity) and those register fine, but I can not get a call to come thru.  I assume the PUBLIC section which has a rule for inbound (condition  destination_number  ^(phone#)$) etc is what I needed.  Is there suppose to be rules in the firewall for inbound calls?  My thought was since FreeSWITCH is listen on the WAN port, that wouldn't be necessary.

    Try setting the inbound destination_number to you 10 digit number without the ^ $. The ^ and $ represent the beginning and end value. If you leave those off and use 10 digits it will accept any call with correct 10 digit number. I have for a long time used ^ and $ but then it is required to know whether the provider is sending the 10 digits or 11 digits and this varies from provider to provider. With just putting the 10 digit number it will look for those 10 digits being contained in the destination_number then it will work for both 10 or 11 digits.

    1. Finally, can't do outbound calls either but my bigger concern is on incoming for now.
      Outbound can be setup the easiest by using the dialplan expression tool that can be found under Gateways.

    To learn how to install FusionPBX on pfSense see the following instructions.
    http://wiki.fusionpbx.com/index.php/PfSense_Install


Log in to reply