Maybe LiveCD Installer problems with snapshot 15th July



  • Hi,

    just to let you know, yesterday I tried to install a machine using this snapshot of the installer. This machine is quite fast and I had no problems with it running Beta3 before (had to install redhat temporarily that's why I had to reinstall pfsense)

    I put config.xml on an USB stick /conf/config.xml. It was found during boot and I selected to use installer mode.
    When it came to partitioning and formatting the drives (selected quick/easy). It complained about subpartitions mounted in the filesystem. It wasn't able to unmount. This was the usb stick.

    I rebooted and tried without supplying any config.xml doing a fresh install.
    This time it worked, but I got an error early on when it tried to populate the filesystem with cpdup. I selected "skip" and it continued installing.

    Sorry I don't have any more details as it was 2am already and I was way too tired so this info might be of no use to you at all..

    However, the box booted but the webinterface was terribly slow. I had to wait for about 2 minutes to load the backup/restore page.
    I restored the config.xml, assigned the correct interfaces, hit save, but nothing happened.. the site continued to load and load.
    After some time I rebooted the box manually.
    At next reboot I had to select the correct interfaces again. I did so, but it was terribly slow.. sitting about 5 minutes at configuring firewall, and another 5 minutes at configuring ipsec.. then again it said "configuring firewall"..

    That's when I shut down and went home :D

    3 questions:
    1. are there known bugs with this snapshot's live installer? Should it work like that (supplying config.xml on an usb stick at boot time for the installer?)
    2. When restoring config.xml through the webinterface (from another box where device names for the nics differ) and we get to chose the right interfaces before it reboots, how long would it take after you hit save to be able to actually hit apply for the box to reboot?
    3. If I did a mistake assigning the correct devices to the interfaces at first boot, after restoring config.xml, let's say I mixed them up, would this cause the big delay in "configuring firewall" and "configuring ipsec"?

    Thanks very much!


  • Rebel Alliance Developer Netgate

    It worked last time I used it, but I haven't booted a CD in a week or so. I haven't tried to use a USB stick with it either.

    If you misconfigured the interfaces it would definitely cause a delay, especially if one of them was DHCP or PPPoE and it waits for that to timeout before continuing.



  • Hmm no DHCP or PPPOE all static links..


Log in to reply