Hardware issue PCNET chipset.



  • Hi. 
    We have set up a load balancing router with pfsense.

    It has 3 10/100 PCI NIC

    The pcn0 interface has caused a kernel panic.    I took a picture of the screen as I am unfamiliar with the debugger.

    I dont know how to proceed besides attempting to locate another network card. If this is an easy fix or anyone needs more information to assist let me know.

    Thanks!

    Here is a printout of dmesg.boot after the crash:

    cat dmesg.boot

    Copyright © 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p5 #0: Sun Dec  6 23:12:34 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_Dev.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Pentium II/Pentium II Xeon/Celeron (349.60-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x652  Stepping = 2
      Features=0x183f9ff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,sep,mtrr,pge,mca,cmov,pat,pse36,mmx,fxsr>real memory  = 536870912 (512 MB)
    avail memory = 510996480 (487 MB)
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ACPI disabled by blacklist.  Contact your BIOS vendor.
    ACPI: Try disabling either ACPI or apic support.
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    pcib0: <intel 82443bx="" (440="" bx)="" host="" to="" pci="" bridge="">pcibus 0 on motherboard
    pir0: <pci 9="" interrupt="" routing="" table:="" entries="">on motherboard
    pci0: <pci bus="">on pcib0
    agp0: <intel 82443bx="" (440="" bx)="" host="" to="" pci="" bridge="">on hostb0
    pcib1: <pcibios pci-pci="" bridge="">at device 1.0 on pci0
    pci1: <pci bus="">on pcib1
    vgapci0: <vga-compatible display="">mem 0xfc000000-0xfcffffff,0xf4200000-0xf4203fff,0xf4800000-0xf4ffffff irq 11 at device 0.0 on pci1
    isab0: <pci-isa bridge="">at device 7.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel piix4="" udma33="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1460-0x146f at device 7.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    uhci0: <intel 82371ab="" eb="" (piix4)="" usb="" controller="">port 0x1400-0x141f irq 9 at device 7.2 on pci0
    uhci0: [GIANT-LOCKED]
    uhci0: [ITHREAD]
    usb0: <intel 82371ab="" eb="" (piix4)="" usb="" controller="">on uhci0
    usb0: USB revision 1.0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 2 ports with 2 removable, self powered
    piix0: <piix timecounter="">port 0x7000-0x700f at device 7.3 on pci0
    Timecounter "PIIX" frequency 3579545 Hz quality 0
    rl0: <accton 10="" 5030="" 5038="" mpx="" 100basetx="">port 0x1000-0x10ff mem 0xf4100000-0xf41000ff irq 10 at device 14.0 on pci0
    miibus0: <mii bus="">on rl0
    rlphy0: <realtek internal="" media="" interface="">PHY 0 on miibus0
    rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    rl0: Ethernet address: 00:e0:29:61:7e:d2
    rl0: [ITHREAD]
    pcn0: <amd 10="" pcnet="" pci="" 100basetx="">port 0x1420-0x143f mem 0xf4100400-0xf410041f irq 7 at device 15.0 on pci0
    pcn0: Chip ID 2623 (Am79C971)
    miibus1: <mii bus="">on pcn0
    lxtphy0: <lxt970 10="" 100="" media="" interface="">PHY 1 on miibus1
    lxtphy0:  100baseFX, 100baseFX-FDX, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 31 on miibus1
    ukphy0:  10baseT, 10baseT-FDX, auto
    pcn0: WARNING: using obsoleted if_watchdog interface
    pcn0: Ethernet address: 00:60:b0:f8:a4:6e
    pcn0: [ITHREAD]
    fxp0: <intel 100="" 82557="" pro="" ethernet="">port 0x1440-0x145f mem 0xf4101000-0xf4101fff,0xf4000000-0xf40fffff irq 9 at device 16.0 on pci0
    miibus2: <mii bus="">on fxp0
    inphy0: <i82555 10="" 100="" media="" interface="">PHY 1 on miibus2
    inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    fxp0: Ethernet address: 00:a0:c9:6c:12:d3
    fxp0: [ITHREAD]
    cpu0 on motherboard
    pmtimer0 on isa0
    orm0: <isa option="" roms="">at iomem 0xc0000-0xc7fff,0xe0000-0xe3fff,0xe4000-0xeffff pnpid ORM0000 on isa0
    atkbdc0: <keyboard controller="" (i8042)="">at port 0x60,0x64 on isa0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0: configured irq 4 not in bitmap of probed irqs 0
    sio0: port may not be enabled
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
    sio0: type 8250 or not responding
    sio0: [FILTER]
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    unknown: <pnp0c02>can't assign resources (memory)
    unknown: <pnp0c02>can't assign resources (memory)
    unknown: <pnp0c01>can't assign resources (memory)
    unknown: <pnp0303>can't assign resources (port)
    speaker0: <pc speaker="">at port 0x61 pnpid PNP0800 on isa0
    unknown: <pnp0c02>can't assign resources (port)
    Timecounter "TSC" frequency 349598671 Hz quality 800
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    ad0: 9541MB <ibm dtta-351010="" t5cca76b="">at ata0-master UDMA33
    Trying to mount root from ufs:/dev/ad0s1a
    WARNING: / was not properly dismounted
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck


    </ibm></pnp0c02></pc></pnp0303></pnp0c01></pnp0c02></pnp0c02></generic></system></at></keyboard></isa></i82555></mii></intel></generic></lxt970></mii></amd></realtek></mii></accton></piix></intel></intel></intel></ata></ata></intel></isa></pci-isa></vga-compatible></pci></pcibios></intel></pci></pci></intel></software></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,sep,mtrr,pge,mca,cmov,pat,pse36,mmx,fxsr>



  • The panic report is not conclusive evidence that there is a problem with the pcn hardware or driver. However I do suspect that pcn is now a rarely used interface and wouldn't be surprised if there are some problems in the driver.

    Does the same thing happen with the pcn disabled or even removed from the box? If so, the panic is probably not related to the pcn. If not, I suggest you try with a new card. The Intel fxp is still pretty commonly used and you can probably pick up a couple on eBay quite cheaply.  There is a known problem with some fxp cards on pfSense 1.2.3 - the driver erroneously thinks some cards have hardware checksum offloading capability and this causes problems if you have hardware checksum offloading enabled. (Workaround: Disable hardware checksum offloading from web GUI: System -> Advanced scroll down to hardware options.)



  • Thanks for the reply.
    I received another panic slightly different.  Im attaching that image. 
    I have since disabled hardware checksum offloading as suggested and I am waiting to see of this error happens again.

    If it does happen again ill try another NIC.

    I have one with an RTL8139C chip which was not detected on boot-up. (speedstream ss1020) Although it shows as supported?
    http://www.freebsd.org/cgi/man.cgi?query=re&sektion=4&manpath=FreeBSD+7.2-RELEASE

    Also I have one with a NC100 chipset (network everywhere) that does not list as supported which I have not tried yet.




  • I think it would be worthwhile running a memory test for a few passes. These sort of problems CAN be caused by intermittent memory faults. There are a number of "system rescue"  and "live" CDs available with memory testers (such as x86memtest) included.



  • Thanks for the help.  When I set Disable hardware checksum offloading from web GUI I also removed a stick of ram I considered to be of questionable integrity and the issue vanished.    I will test the ram again at a later date, but I believe the hardware checksum offloading was the problem.

    This system was originally running off of a different board/cpu/memory with the same NICs with the same problem.

    Either way problem solved thanks for the assistance.


Log in to reply