FreeSWITCH config advice (lan & external)



  • Hello!

    I have searched through a hugh amount of freeSWITCH chat on this forum, but cannot really solve my question. I think especially that the lan.profile has now been removed from the FreeSWITCH package – although that might be a red herring!

    This is my setup:

    static public ip -> pfSense/FS box WAN (81.12.x.x)
    linksysATA device is connected to the pfSense LAN port (192.168.1.6 -> 192.168.1.1)

    From the standard install, I can see that FreeSWITCH is listening on my public WAN IP address
    I added my domain name to the vars.xml file, so now that is also shown as an alias to the internal profile. Good so far!

    I can connect ok from the wan connected users (user registered ok in status page).

    I cannot connect ok from the lan connected linksysATA.

    I can imagine it is because my lan device is on the lan ip, and freeswitch is only listening on the wan ip.

    What would be the best practise to solve this ?

    I am using pfSense 1.2.3 with non-dev freeswitch package. Both downloaded/installed yesterday.

    Thanks for any tips.



  • update:

    I reinstalled pfSense from the LiveCD and added the FreeSWITCH package. Only change in config has been to vars.xml

    The LinksysPAP-NA connecting through the LAN interface now shows registered in the FreeSWITCH STATUS tab. However, the Linksys is self-rebooting every 10-20 seconds. The dial tone can be heared at the phone handset for a couple of seconds every 10 seconds.

    The Linksys proxy setting is also set to "phone.mydomain.com".
    The pfSense hostname is "phone.mydomain.com".

    I mention that as from the WAN side, phone.mydomain.com resolves to the public ip. From the LAN side, perhaps it resolves to the local ip of the pfSense server (ie. 192.168.1.1)… If that is what pfSense would do; if that would make any difference; - grasping at straws!

    Please help if anyone has some spare time & ideas!



  • In the logs, I have a few occurences of:

    2010-07-22 17:02:33.625528 [ERR] sofia_reg.c:1308 NO CONTACT!

    Search engine does not provide any clues  ???



  • I removed the LAN profile because it caused a lot of confusion and difficulty for people there are two others ways that are easier to do.

    1. By default FreeSWITCH binds both the internal and external profile to the WAN IP Address. If you setup the domain like you did in the vars.xml from the vars tab you can setup the linksys to register to that domain and pfsense should allow hitting the WAN IP address from the inside. If you have a dynamic WAN IP then you can use dynamic dns to keep the domain updated with the right IP address.

    or

    2. Alternative method to set this up is that you make the internal sip profile listen on the LAN ip address and leave the external profile binding to the IP on the WAN which it already does by default. To set the internal sip profile so that it binds to the wan ip you open the internal sip profile and change the rtp-ip and sip-ip then set those to use the LAN IP address.



  • @mickeyholland:

    The LinksysPAP-NA connecting through the LAN interface now shows registered in the FreeSWITCH STATUS tab. However, the Linksys is self-rebooting every 10-20 seconds. The dial tone can be heared at the phone handset for a couple of seconds every 10 seconds.

    I have not had a Linksys PAP reboot every 10-20 seconds. Make sure you have it plugged into a good ethernet cable and that the power plugged in completely.

    @mickeyholland:

    The Linksys proxy setting is also set to "phone.mydomain.com".
    The pfSense hostname is "phone.mydomain.com".

    Should be fine.

    @mickeyholland:

    I mention that as from the WAN side, phone.mydomain.com resolves to the public ip. From the LAN side, perhaps it resolves to the local ip of the pfSense server (ie. 192.168.1.1)… If that is what pfSense would do; if that would make any difference; - grasping at straws!

    Ping your domain and see what ip address you get it should give you the WAN IP.



  • mcrane: Thank you for your help.

    I tried connecting with an xlite softphone at the lan, and calling the external user on the wan. Works fine. Along with your answers it suggests my FS configuration is correct, so it might be something wrong with the lan linksys config, or maybe the pfsense firewall config. Maybe some firewall rules, port forwarding or dns setting…

    Anyhow, I will have another bash after my annual leave, which starts tomorrow for 2 weeks - hoorrah!

    :)


Log in to reply