CPU Frequency Set to 50mHz, Unchangeable, on VIA Eden



  • All,

    I've got a pfSense 2.0 BETA3 (July 6, 04:43:07 build) install running on a Jetway VIA Eden 1200mHz board, as a test firewall.  I've been noticing that, while the performance of traffic passing is fine, the GUI and SSH performance of the firewall has been abysmal.  Finally looked in to the issue, and found that the CPU is running at 50mHz, and the frequency cannot be changed:

    sysctl dev.cpu.0.freq

    dev.cpu.0.freq: 50

    sysctl dev.cpu.0.freq=1200

    dev.cpu.0.freq: 50
    sysctl: dev.cpu.0.freq: Operation not permitted

    Things look mostly OK in ACPI:

    sysctl hw.acpi

    hw.acpi.supported_sleep_state: S1 S4 S5
    hw.acpi.power_button_state: S5
    hw.acpi.sleep_button_state: S1
    hw.acpi.lid_switch_state: NONE
    hw.acpi.standby_state: S1
    hw.acpi.suspend_state: NONE
    hw.acpi.sleep_delay: 1
    hw.acpi.s4bios: 0
    hw.acpi.verbose: 0
    hw.acpi.disable_on_reboot: 0
    hw.acpi.handle_reboot: 0
    hw.acpi.reset_video: 0
    hw.acpi.cpu.cx_lowest: C1
    hw.acpi.thermal.min_runtime: 0
    hw.acpi.thermal.polling_rate: 10
    hw.acpi.thermal.user_override: 0
    hw.acpi.thermal.tz0.temperature: 52.0C
    hw.acpi.thermal.tz0.active: 0
    hw.acpi.thermal.tz0.passive_cooling: 1
    hw.acpi.thermal.tz0.thermal_flags: 1
    hw.acpi.thermal.tz0._PSV: 50.0C
    hw.acpi.thermal.tz0._HOT: -1
    hw.acpi.thermal.tz0._CRT: 60.0C
    hw.acpi.thermal.tz0._ACx: 50.0C -1 -1 -1 -1 -1 -1 -1 -1 -1
    hw.acpi.thermal.tz0._TC1: 4
    hw.acpi.thermal.tz0._TC2: 3
    hw.acpi.thermal.tz0._TSP: 60

    And the CPU looks OK, otherwise:

    sysctl dev.cpu.0

    dev.cpu.0.%desc: ACPI CPU
    dev.cpu.0.%driver: cpu
    dev.cpu.0.%location: handle=_PR_.CPU0
    dev.cpu.0.%pnpinfo: _HID=none _UID=0
    dev.cpu.0.%parent: acpi0
    dev.cpu.0.freq: 50
    dev.cpu.0.freq_levels: 1200/7000 1050/6125 1000/6000 875/5250 800/5500 700/4812 600/5000 525/4375 450/3750 400/4000 350/3500 300/3000 250/2500 200/2000 150/1500 100/1000 50/500
    dev.cpu.0.cx_supported: C1/0 C2/80 C3/800
    dev.cpu.0.cx_lowest: C1
    dev.cpu.0.cx_usage: 100.00% 0.00% 0.00% last 500us

    Any thoughts?  I've done about as much as I can figure out.  I'm assuming that the problem is between my BIOS' ACPI tables and FreeBSD.

    Thanks!



  • Isn't that something that should be set in the BIOS?



  • Well, no, not as far as I can tell.  This seems to be a straight-forward ACPI problem.  Does anyone have a thought on how to deal with this?



  • Disable ACPI maybe?  That sounds like a BIOS bug, any updates available?



  • Yep, disabling ACPI works around the problem, but it prevents speedstep, too.  That's a major problem, as this is a fanless system.  When ACPI is disabled, the CPU always runs at 1.2gHz, and overheats, eventually.

    As far as I can tell, there are no newer BIOSes for the board, a Jetway J7F2WE-1G2.

    I've also tried to modify sysctl.conf, to ignore the faulty temperature reading, to no avail.

    Thanks!



  • @ajacocks:

    I've also tried to modify sysctl.conf, to ignore the faulty temperature reading, to no avail.

    I don't see anything in the temp output that looks out of whack, maybe I'm missing something, but that's all near identical to a similar VIA board I'm running. Two diffs, my tz0.temperature shows 46.0C, and my hw.acpi.thermal.tz0.thermal_flags is 1. Everything else is completely identical. That's post-BIOS update though, initially the BIOS was reporting its temp as something like -500 degrees C, though that didn't cause any problems other than a bunch of annoying log messages that it was ignoring absurd values.

    Which value are you trying to set?  Maybe this will help if you haven't seen it.
    http://www.freebsd.org/cgi/man.cgi?query=acpi_thermal&apropos=0&sektion=0&manpath=FreeBSD+8.0-stable&format=html



  • Well, it tuned out that a BIOS update did fix the problem.  No thanks to Jetway for labeling the BIOS update as the same version number that I already had installed, to make it seem like I was already up to date.

    Anyway, thanks for the help, and things seem to be working OK, now.


Log in to reply