USB Hub connected to opt1



  • Hi,

    now i'm using pfsense with this configuration:

    WAN-> USB wireless NIC, connected to an adsl line via wireless, with gateway 192.168.1.1
    LAN-> PCI wireless NIC, with dhcp (192.168.5.1). It's work fine, here I connect all my pcs, and I have internet without mayor problems.
    OPT1-> ethernet NIC, wired. I've got this interface with static configuration, bridge with LAN and with a rule in OPT1 firewall that allows dhcp assign (UDP 67-68 ports).

    What I'm trying is to get OPT1 serving dhcp to a usb hub, where I connect usb devices (printer, hard disk, etc.), getting an ip in the same range (192.168.5.1) in order to be detected and used by my pcs (that are connected to LAN).

    I tried different cables rj45, and that's not the problem.

    I' don't know if the problem is in the firewall rules (nothing interesting in the log) or in the OPT1 configuration.

    Thanks!



  • If I understand what you're attempting, you're trying to assign IPs to USB devices? USB is not a network, you can't assign IPs to USB devices.



  • Thanks for your answer.

    Well, this device (http://www.belkin.com/uk/networkusbhub/) works like that. It's normaly connected to a router, as any computer (into a rj45 port), and gets an ip from the router in the same network. Then, through an specific software installed in the computers you can use any usb device that is attached to the hub.

    What gets the ip assigned is the hub, not the usb device.

    Now I know that when a neutral router is connected to the OPT1 ethernet port (the same that doesn't work with the usb hub), is detected and works fine (is assigned with an ip inside my lan, in this case 192.168.5.245). So if I want to use the usb hub, I've to do it through the router (with its own subnet). I tried several options but I don't find the solution to make OPT1 assign an ip direectly to the hub.



  • @able980:

    Well, this device (http://www.belkin.com/uk/networkusbhub/) works like that. It's normaly connected to a router, as any computer (into a rj45 port), and gets an ip from the router in the same network.

    This hub gets the IP address by DHCP?

    @able980:

    I tried several options but I don't find the solution to make OPT1 assign an ip direectly to the hub.

    Did you try power cycling the device after connecting it to OPT1? Otherwise it might have an IP address from a previous connection or may have timed out on requesting an IP address.

    @able980:

    Now I know that when a neutral router is connected to the OPT1 ethernet port (the same that doesn't work with the usb hub), is detected and works fine (is assigned with an ip inside my lan, in this case 192.168.5.245).

    I don't understand the details of this: You have a LAN interface and OPT1 interface. How did the router get an address on your LAN subnet when you connected it to OPT1? You have LAN and OPT1 bridged? It was previously connected to LAN and you moved it to OPT1. "IP inside my lan" doesn't mean it was connected to my LAN interface?

    Have you enabled DHCP server on OPT1? From web GUI Services -> DHCP Server, click on the OPT1 tab, fill in the details and click the save button.

    What is your firewall rule on OPT1 to allow DHCP? Maybe its too restrictive.



  • This hub gets the IP address by DHCP?

    Yes, you can configure with DHCP and static IP, here is the hub setting page:

    Did you try power cycling the device after connecting it to OPT1? Otherwise it might have an IP address from a previous connection or may have timed out on requesting an IP address.

    Of course, I do it everytime I change the settings of pfsense or the hub.

    I don't understand the details of this: You have a LAN interface and OPT1 interface. How did the router get an address on your LAN subnet when you connected it to OPT1? You have LAN and OPT1 bridged? It was previously connected to LAN and you moved it to OPT1. "IP inside my lan" doesn't mean it was connected to my LAN interface?

    Yes, OPT1 is bridge with LAN. When I tried that with the router I attached it to OPT1 and the router got a WAN ip 192.168.5.X. It was not previously connected to LAN.

    Have you enabled DHCP server on OPT1?

    Yes, I tried it.

    What is your firewall rule on OPT1 to allow DHCP? Maybe its too restrictive.

    This is are my firewall rules for OPT1:

    In my last test, with OPT1 active, DHCP (not static), bridge with LAN and the hub settings with static ip, I got for the first time this messeage in the log:

    Jul 25 17:08:01 php: : Processing -
    Jul 25 17:08:01 php: : Processing start -
    Jul 25 17:08:01 php: : HOTPLUG: Configuring optional interface - opt
    Jul 25 17:08:01 php: : DEVD Ethernet attached event for fxp0
    Jul 25 17:08:01 php: : Processing fxp0 - start
    Jul 25 17:08:00 kernel: fxp0: link state changed to DOWN
    Jul 25 17:08:00 check_reload_status: rc.linkup starting
    Jul 25 17:07:59 kernel: fxp0: link state changed to UP

    But nothing happends after this.

    Thanks for your help!




  • Please configure the system as you intend to use it and then describe it. Its not obvious why you have bridged LAN and OPT1. Perhaps your LAN switch is full and you had a spare interface on pfSense. I would prefer not to debug whatever you have put together now and then run into a new set of problems when you change to your preferred configuration.

    Please look at the Status -> Interfaces page in pfSense when your usb hub is connected to OPT1. Is the Status of OPT1 "up"? If not, you probably need a cross over cable. More modern NICs and higher featured NICs don't need a cross over cable when connected together without a switch. Older NICs and less featured NICs do need a cross over cable so transmitter at each end is connected to receiver at the other end.



  • Thanks for your answer.

    I have OPT1 bridge because LAN interface is a wireless card, and I cannot connect the hub via wireless, that's why I need a wired connection through OPT1. If I want to use the usb devices connected to the hub from my pcs (that are connected to LAN via wireless) I need the hub to get an ip in the same network as the LAN, that's why is bridged.

    The status of OPT1 is "no carrier". In any case, I'll try a cross over cable and then I'll see.

    Thanks again!



  • It´s was the cable.

    Everything fine with a crossover cable: http://img251.imageshack.us/img251/9468/pfsense.jpg

    Thanks!!



  • Thanks for reporting back.

    Nice diagram.


Log in to reply