Newbie Install - XP Clients, pfSense Router



  • Hi,

    I've got the following setup:
    WAN -> fxp0 (DHCP) -> pfSense Box -> de0 (192.168.0.1) -> Switch -> Client PCs

    However, it's not working quite as I'd hoped.
    Firstly, our WAN requires a proxy to be set for internet access - I can't see anything in the pfSense menus to configure a proxy (so even if the clients could access the network, they wouldn't have internet access.

    Secondly, the DHCP server on de0 doesn't seem to be working - the XP client PC I'm testing this with doesn't get allocated an IP address (I've set pfSense to give out addresses in the range 192.168.0.100 - 192.168.0.200).  If I set the IP address manually then the network connection on the XP client is happy but I can't ping anything.

    Thirdly, I can't get at the web gui at all - nothing will ping/connect to the address stated for fxp0 (and the XP clients can't ping 192.168.0.1 or access it via iexplore).

    So I've hit a minor dead end here…

    Any and all help gratefully received!  I'm sure it's not too complicated!



  • @Imajica:

    Hi,

    I've got the following setup:
    WAN -> fxp0 (DHCP) -> pfSense Box -> de0 (192.168.0.1) -> Switch -> Client PCs

    However, it's not working quite as I'd hoped.
    Firstly, our WAN requires a proxy to be set for internet access - I can't see anything in the pfSense menus to configure a proxy (so even if the clients could access the network, they wouldn't have internet access.

    setting a proxy server you do in youre internet browser
    @Imajica:

    Secondly, the DHCP server on de0 doesn't seem to be working - the XP client PC I'm testing this with doesn't get allocated an IP address (I've set pfSense to give out addresses in the range 192.168.0.100 - 192.168.0.200).  If I set the IP address manually then the network connection on the XP client is happy but I can't ping anything.

    Thirdly, I can't get at the web gui at all - nothing will ping/connect to the address stated for fxp0 (and the XP clients can't ping 192.168.0.1 or access it via iexplore).

    So I've hit a minor dead end here…

    Any and all help gratefully received!  I'm sure it's not too complicated!

    best is to rest pfsense back to the factory defaults and start again
    with the config ( on http://192.168.1.1 )
    is the network on the wan side a prived network ?
    if so then u need to uncheck the default block prived networks option on the wan interface

    you can't connect to the wan ip by default
    only lan ip you can connect to
    if you want to connect to the wan ip you have to turn on nat reflection



  • @jeroen234:

    setting a proxy server you do in youre internet browser

    Ah.  Then pfSense won't do what I need it to do…



  • @Imajica:

    Hi,

    I've got the following setup:
    WAN -> fxp0 (DHCP) -> pfSense Box -> de0 (192.168.0.1) -> Switch -> Client PCs

    However, it's not working quite as I'd hoped.
    Firstly, our WAN requires a proxy to be set for internet access - I can't see anything in the pfSense menus to configure a proxy (so even if the clients could access the network, they wouldn't have internet access.

    Sounds like you need to configure the WAN to a static IP and setup an outbound NAT. That should facilitate your WAN proxy settings.



  • @Imajica:

    @jeroen234:

    setting a proxy server you do in youre internet browser

    Ah.  Then pfSense won't do what I need it to do…

    Yes, it will. What he's saying is that you just need to set the proxy option in the browser, not at the router.


Locked