Type and Behaviour Field in Load Balancer



  • Hi everyone, :)

    I have installed this snapshot (pfSense-2.0-BETA3-20100724-1327.iso.gz) just to give a try because i have read that squid-guard is working already in the latest snapshot of 2.0 and I was happy that it is. Then try the load balancing feature to test if fail-over is working with squid but am a bit stuck because the interface of the load balancer seems to be different. I cannot locate the behaviour and type field in the Pool Tab . Can you please give me some tips on how to enable it or see it elsewhere if it was moved. :)
    Please see attached.

    Thank you very much.



  • Rebel Alliance Developer Netgate

    For outbound Load Balancing, use System > Routing, gateway groups.

    IIRC you need to setup rules on the floating tab to match the outgoing squid traffic and use a gateway group, but I haven't tried it myself.



  • thank you very much sir jimp. atleast i have the idea how to do it and i'll just play around with the settings. :)



  • by the way sir, regarding with the Pool entry, if my understanding is correct this serves as the heartbeat between gateways. why is the port field cannot be leave empty or should i say what is the default or recommended port to use?

    thanks once again for your dedication and time answering our questions. :)


  • Rebel Alliance Developer Netgate

    You don't setup pools or anything in the Load Balancer in 2.0 for outbound (gateway) load balancing.

    It's all under Gateway Groups.



  • ah i see that's why even if i deleted those pools, load balancing is still working fine. :)

    Now am still in the process of testing that floating rules so squid will be able to fail-over to another gateway. I cannot get it going following the procedure of sir ermal http://forum.pfsense.org/index.php/topic,15272.0.html. I know you have said that you haven't gone that far yet  but i believe in you and the rest of the pfsense community can achieve it to help more especially newbies like me. :)

    hope to read more successful threads about it.

    once again thank you for such kind responses.


Log in to reply