Why internet Speed 10Mb/s when it should be more then 50 Mb/s



  • hi

    In my pfsense box, both Ethernet card is 100-1000 Base T

    Wan has connection to 1000BASE
    as :
    ifconfig re0
    re0:
            media: Ethernet autoselect (1000baseTX <full-duplex>)
            status: active

    Lan :
    xl0: f
            media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active

    So if i do  a broadband speed test, i should see 40Mb/s download speed
    but its only shows 10Mb/s speed

    that means data is going out via pfsnese by 10Mb/s

    how to set this one to 100Mb/s ??

    I guess its trafiq sharping, but is that the way ??
    how will i do this on trafiq sharping ? or there is any other options i am missing
    thanks</full-duplex></full-duplex>



  • I need some more specifics.

    When you look at Status-> interfaces what do you get for Media.
    Example: Media  100baseTX <full-duplex>Also do another speed test at speedtest.net and report your upload and download speeds. Also consider any traffic you are consuming with other applications such as servers, bit-torrent, or anything else that uses bandwidth while you are testing.</full-duplex>



  • HI Thanks
    Sorry due to night ,i did not able to reply.

    WAN interface (re0)
    Status  up
    MAC address 00:06:4f:6a:8a:fc
    IP address 192.168.88.1 
    Subnet mask 255.255.255.192
    Gateway 192.168.88.2
    ISP DNS servers xx.xx.xx.x
    Media 1000baseTX <full-duplex>In/out packets 100176/105082 (39.96 MB/14.75 MB)
    In/out errors 0/0
    Collisions 0

    LAN interface (xl0)
    Status up
    MAC address 00:01:02:dc:87:b3
    IP address xxx.xxx.xxx.1 
    Subnet mask 255.255.255.0
    Media 100baseTX <full-duplex>In/out packets 351339/136575 (31.98 MB/57.39 MB)
    In/out errors 0/0
    Collisions 0

    So as you can see, i got 100BAse Media.

    if i connect a pc with the ISP modem directly, then i Speed test will show report of 33Mb/s download

    But if i connect pc behind this pfsense router then i get maximum of 10Mb/s download speed

    its always, and  our company does not allow any bit torrent or highly bandwidth consuming application. inface if i look at bandwidthd, yesterday our total bandwidth out was 100MB, and may be it will go higher to 500Mb which is a nothing for internet users

    Please have a look at attached picture ,




    </full-duplex></full-duplex>



  • Is this ADSL? Does your ISP require a different MTU setting.

    Also some NIC drivers act weird, try disabling hardware checksum offloading  web GUI: System -> Advanced, scroll down to Hardware Options and check the box Disable Hardware Checksum Offloading)



  • hi thanks
    I think the problem is Ethernet card of pfsense(real tek) and the router port.

    Today i added another router. and from internal pc i can get 34 M/b speed!!

    so it guess there is problem between duplexing …..


Log in to reply