Strange DHCP leases with Dlink 2100 AP in client mode



  • I am using the latest version of pfsense (1.0.1) with DHCP server configured with static leases. the LAN interface of the pfsense box is connected to an as access point
    wireless clients connected directely to the access point get the correct IP (assigned by dhcp).
    some client using a wireless client (Dlink AP, or atlantis configured in CLIENT MODE) connected to their ethernet card don't get the correct IP from DHCP

    • If I add the mac adress of their ethernet card in DHCP static map === NO correct IP
    • If I add the mac of the wireless client === they don't obtain the correct IP also

    It's very strange !!

    Anybody have an idea on how to assign static leases for client connected behind an access point working in client mode ? ?

    Thanks



  • Because the DHCP server is getting the MAC address of the wireless access point in client mode. Not sure how to fix. I had this happen when trying to setup a captive portal with an access point. When one user logged in it logged in the access point and not the individual client.



  • There has been a long discussion on that at the m0n0 list. It came down to be buggy accesspointfirmware. Search the m0n0 list. Especially the popular linksys accesspoints that run 3rd party software seem to be affected.



  • it is true that I have a wireless WDS network using linksys and buffalo routers. but this problem happens when i use access point in client mode with or without WDS.
    anyway ddwrt firmware works perfectly with pfsense


Log in to reply