SWISSCOM TV configuration



  • Swisscom TV works with following configuration:

    take this config as a starting point for your own needs, specially take a look at the firewall rules.

    tested with pfsense 2.0-beta 4, August 1 build

     <igmpproxy><igmpentry><ifname>lan</ifname>
    			<threshold>1</threshold>
    			<type>downstream</type>
    
    <address>192.168.1.0/24</address></igmpentry> 
    		 <igmpentry><ifname>wan</ifname>
    			<threshold>1</threshold>
    			<type>upstream</type>
    
    <address>224.0.0.0/4 195.186.0.0/16 1.1.1.0/24</address></igmpentry></igmpproxy> 
    
     <rule><id><type>pass</type>
    			<interface>lan</interface>
    			 <allowopts><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><protocol>igmp</protocol>
    			<source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></allowopts></id></rule> 
    		 <rule><id><type>pass</type>
    			<interface>lan</interface>
    			 <allowopts><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><protocol>udp</protocol>
    			<source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></allowopts></id></rule> 
    
    		 <rule><id><type>pass</type>
    			<interface>wan</interface>
    			 <allowopts><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><protocol>igmp</protocol>
    			<source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></allowopts></id></rule> 
    		 <rule><id><type>pass</type>
    			<interface>wan</interface>
    			 <allowopts><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><protocol>udp</protocol>
    			<source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></allowopts></id></rule> 
    

    regards,

    jan

    ![igmpproxy settings.jpg](/public/imported_attachments/1/igmpproxy settings.jpg)
    ![igmpproxy settings.jpg_thumb](/public/imported_attachments/1/igmpproxy settings.jpg_thumb)
    ![firewall WAN rules.jpg](/public/imported_attachments/1/firewall WAN rules.jpg)
    ![firewall WAN rules.jpg_thumb](/public/imported_attachments/1/firewall WAN rules.jpg_thumb)
    ![firewall LAN rules.jpg](/public/imported_attachments/1/firewall LAN rules.jpg)
    ![firewall LAN rules.jpg_thumb](/public/imported_attachments/1/firewall LAN rules.jpg_thumb)
    ![PASS ALL Setting for all RULES.jpg](/public/imported_attachments/1/PASS ALL Setting for all RULES.jpg)
    ![PASS ALL Setting for all RULES.jpg_thumb](/public/imported_attachments/1/PASS ALL Setting for all RULES.jpg_thumb)



  • can any1 confirm if the above works for other providers and no config change is required with recent snaps to make it work.



  • i have the below in my config and systemlog shows the below and i have no clue if igmp proxy is working or no.





Log in to reply