Computer not able to have an ip from dhcp server



  • hi

    i have a client used to connect to my network like many other existing users, 2 days ago the client wasnt able to have an IP adress, the wirless on the computer shows connected, but with exclamation mark saying limited connectivity, i tried the laptop on other network with same configuration and the laptop connected and got an IP from the server, so what is wrong here?

    help really appreciated

    hadi57



  • I have three Windows laptops on my home network. From time to time the wireless link dies and the user needs to restart it by disabling then enabling the wireless interface on the laptop.



  • i even formated my client computer, still get limited connectivity



  • I don't know if this is relevant. There is a known Windows problem (in Vista and XP?) with DHCP. It requires a registry tweak.
    Both the Windows Vista laptops in my home required the registry tweak. On both laptops, "all of a sudden" the wireless link stopped working due to DHCP not acquiring an IP address. I SUSPECT Windows update changed something.



  • i found out something new, my i have 2 groups of buildings connected to the server, group 1 getting the connection via wireless bridge, group 2 getting the connection via coxial cable using corinex cable modem, the thing is if my client go to group 1, her laptop get IP from my server, but if she move to group 2 buildings, she gets limited or no connectivity.

    wireless bridge to group 1 buildings –> switch --> wireless access points every where
    server
                  corinex coaxial cable to group 2 buildings --> switch --> wireless access points every where



  • Your network "diagram" suggests your server (pfSense?) has a NIC for the group 1 buildings and another NIC for the group 2 buildings. DHCP is enabled on the NIC for group 2 buildings? Have you looked in the DHCP log (web GUI: Status -> System logs, click on the DHCP tab) for a request from the client?



  • sorry forgot to mention there is a switch after the server, both network connected to the switch.  what confuses me the client was able to connect all the time to this network, when she started to face this problem, i thought maybe she updated her windows 7 and the driver wasn't good to connect to my AP11b access points so i formated her net-book with fresh installation of win7 but no luck. i also have another client just got herself a new net-book with windows 7 installed not able to connect to 11b so i had to give her a usb wireless so she managed to connect now.


Log in to reply