Snort 1.31 Problem [Solved]



  • Not sure if this is unique to me but after deinstalling 1.27 and installing 1.31 snort will not run due to this error in the logs "snort[40376]: FATAL ERROR: parser.c(5161) Could not stat dynamic module path "/usr/local/lib/snort/dynamicrules/": No such file or directory."

    Anyone else having this problem?



  • Just to let others know the issue was from not running update. I thought my old/manually installed rules would have worked but they didn't. However, I have run across another lil bug for me. I get this error in my log now "snort[44655]: FATAL ERROR: Unable to open rules file "/usr/local/etc/snort/snort_55561_vlan0//usr/local/etc/snort/snort_55561_vlan0/rules/snort_attack-responses.rules": No such file or directory."



  • Not sure what was causing the issue but after I disabled the offending category for each interface that was failing the snort service started working.

    After that I noticed that a lot of my rules were not there. I guess that may have been due to manually installing the rules when update was broken. I then noticed nothing was selected under "Install Snort.org rules" in Global Settings. After selecting "Install Basic Rules or Premium rules" and updating rules again all rules returned.

    Hope this helps people.


Log in to reply