FTP kernel panics have returned for Multi-Wan



  • http://forum.pfsense.org/index.php/topic,20199.0.html

    This seems to have returned. Upgraded from Beta1 to Beta4 today and accessing any FTP site would cause the router to reboot. We are a multi-wan installation.

    Creating a firewall rule on LAN forcing outbound traffic on ports 20,21 and specifying WAN's gateway for the traffic solves the problem, but this will require debugging I think. I took a picture of the panics I could email to someone. I attempted to type bt to get a backtrace a few times, but it did not work. It seems to say press any key not to reboot.. then reboots anyway.

    I appreciate all the hard work that goes into pfSense. it is a really nice piece of work.

    I am using the 2010-08-12 snapshot.



  • what type of WANs do you have? (DHCP, static, PPPoE, …)

    can't get a backtrace with the default kernel anymore as debugging has been disabled by default, may not need it as long as we can replicate the issue.



  • Two static and one PPPoE. I disabled/deleted the PPPoE interface (on the PPP tab in (Assign), too) and disabled that whole interface so I was left with the two static interfaces, but that didn't seem to help. This was my first thought.

    Now that I think about it, I didn't reboot after bringing down the PPPoE interface though, so perhaps it was running in the background?



  • You tried to force traffic through the second static gateway or the pppoe(dynamic one)?



  • I had not tried that.

    I tried it tonight and it worked normally. As long as any gateway was specified other than the gateway group, FTP traffic functioned normally. I did not investigate deeply enough to know if I was in active or pasv mode, but I'm 82% sure I was in active mode. I can keep digging on this if that would help.

    I may also need to reinstall to test properly… the last panic cycle appears to have damaged the console and left some significant FS corruption. I can still SSH in and that works mostly as expected, but no menu on local console. the Config XML file appears OK though.

    If I specify the gateway group in the gateway dropdown,  I get panics again.



  • I am still experiencing the same issue. Build i386 pfSense-Full-Update-2.0-BETA4-20100826-0844. Like above the issue is resolved by creating firewall rules to catch all port 20,21 and define the gateway of single interface.



  • Can you please test with snapshots later than this post.
    I have committed a fix for this.



  • We just got a kernel panic on this build: "Wed Sep 1 11:07:08 EDT 2010" though I can't tell if it was due to FTP. I've made the change to the FTP rules as described below, and will report back if this results in stability.



  • Upgraded to i386 build 2.0-BETA4-20100901-2344 this morning and the issue seems to be resolved. Downloaded several files via FTP and no kernel panic.


Log in to reply