[Solved] console not functioning on new install



  • 2.0-BETA4 (amd64)
    built on Mon Aug 16 02:32:13 UTC 2010
    full install

    I turned on the console from the web UI and rebooted pfsense. The boot appeared normal from the console, except at the end of the boot sequence, at the moment where I should see the status of my interfaces followed by the numbered console options, things stop. I don't recall exactly the last message on the console, but it was something familiar, like "bootup complete". The console was unresponsive at this point.

    PFSense appeared to be functioning normally otherwise. Traffic was routing and the web UI and ssh server were connectable. I checked /boot/loader.conf and the console="comconsole" line was at the bottom, as expected.

    After rebooting again, I saw on the console the FreeBSD boot prompt, but its appearance was corrupted. It was recognizable but mostly not readable. The countdown timer was visible though, and when it got to 1 the screen froze. It was not entirely unresponsive at that point, but all I could make it do was to drop the cursor down a line by hitting enter on the keyboard. Meanwhile, pfsense appears to be functioning fine otherwise.

    My terminal program is set to 9600,8N1, which has always worked in the past.

    Did I break something? The only thing I can think of is a BIOS setting I turned on that gives limited POST access over the serial port. Perhaps it is not handing off correctly. I will try disabling this, but in the mean time I wanted to ask if my symptoms are part of a known issue.

    Thanks.



  • This seems to be related to the rogue bootblocks I described in another thread. Works fine when using the correct boot loader.


Log in to reply