PPP configuration GUI (3G modem) quirks



    1. Password box in the PPP Configuration section of an interface configuration, the left hand end of the data entry area is on the left of the lock symbol so the first character typed overlays the lock graphic and is apparently not displayed.

    2. Previously configured Service Provider information is not displayed when an interface configuration is edited after saving a previous configuration.



  • Can you show screenshots on this?



  • I'm running 2.0-BETA4  (i386)
    built on Wed Aug 18 21:58:53 EDT 2010
    FreeBSD 8.1-RELEASE

    The attached screen shot shows that the service provider details are not displayed. I've configured these details a number of times: Australia/Optus/prepaid

    I clicked in the Password box and the blinking cursor is inside the orange circle around the closed lock and the cursor is aligned on or close to the left hand edge of the lock. Consequently the "blob" for the first password character is over the body of the lock and it looks as if nothing was typed.

    Here's the ppps section of the config.xml file:

    <ppps><ppp><ptpid>0</ptpid>
                            <type>ppp</type>
                            <if>ppp0</if>
                            <ports>/dev/cuaU0.0</ports>
                            <username><password><uptime><apnum><bandwidth><mtu><mru><phone>*99#</phone>
                            <apn>preconnect</apn></mru></mtu></bandwidth></apnum></uptime></password></username></ppp></ppps>

    ![Desk 1_001.png](/public/imported_attachments/1/Desk 1_001.png)
    ![Desk 1_001.png_thumb](/public/imported_attachments/1/Desk 1_001.png_thumb)



  • @wallabybob:

    1. Previously configured Service Provider information is not displayed when an interface configuration is edited after saving a previous configuration.

    That part is actually by design - it does not store your selection there, it only fills the appropriate settings for what you select. Not the best design though IMO.
    http://redmine.pfsense.org/issues/830


Log in to reply