OpenVPN: Windows clients use option dns server as their default dns



  • Hi,

    I got a problem with windows clients connecting via OpenVPN.
    As long as I provide them with pfsense's dns server (forwarder), they use it as their default dns server. It doesn't matter whether I set a default domain or not.

    The reason I don't want this to happen is that I'm overriding the hostname/address of a particular host in the lan in the dns forwarder. This should only take effect for local clients but not remote clients.

    Is there any way I can solve this remotely via some switches in the openvpn server config?

    Thank you very much!



  • That's how it's supposed to work. Default domain has nothing to do with that. OpenVPN can't control that. That's a Windows question (you can muck with the binding order but it gets to be a real PITA with any type of VPN on Windows).



  • Thank you!

    So I have to set up bind somewhere, or does tinydns allow different settings per network too?



  • tinydns doesn't allow that AFAIK, believe you'll need BIND.


Log in to reply