Getting "ifconfig: interface ath0 does not exist" error



  • I am using latest pfsense embedded firmware (.90) and installed on Soekris 4801 with  Atheros 5354 MP PLUS ARIES2 4G (miniPCI) wireless. I was able to get pfsense up and running, but it is not seeing the ath0 at all, I went to the shell and issued some commands:

    ifconfig ath0

    ifconfig: interface ath0 does not exist

    ifconfig ath0 inet 192.168.1.21 netmask 255.255.255.0 ssid apname;

    ifconfig: interface ath0 does not exist

    dmesg | grep ath0

    ath0: <atheros 5212="">mem 0xa0010000-0xa001ffff irq 11 at device 14.0 on pci0
    ath0: Ethernet address: 00:02:6f:21:e3:3a
    ath0: mac 5.9 phy 4.3 radio 3.6</atheros>

    Any idea why it is not seeing ath0? it should be able to work under FreeBSD 5.x and 6.x.

    Thanks,
    Richard



  • Did you assign the interface?



  • I tried that, but I dont see an option for ath0 in the drop list.  See the attached image snapshot of webgui showing only 3 interfaces choice.

    @sullrich:

    Did you assign the interface?





  • Click the + icon.



  • @sullrich:

    Click the + icon.

    No option for + icon, I tried deleting the OPT1 interface then I saw + icon.. I clicked on that, and that is only 3 options showed SIS0 thru 3. nothing about ath0..





  • Can you post the full dmesg?  It might contain more info that someone will find useful.

    –Bill



  • Get the newest version (0.92), it has a newer HAL/driver for ath.
    And it should support that card.
    Also add all the dmesg lines regarding ath.
    And a pciconfg -vl from the shell would be nice.



  • I replaced the image with 0.92 and it now see the wireless ath0.. Thanks guys.

    If you still need the dmesg on this new release, let me know.

    Richard

    @lsf:

    Get the newest version (0.92), it has a newer HAL/driver for ath.
    And it should support that card.
    Also add all the dmesg lines regarding ath.
    And a pciconfg -vl from the shell would be nice.


Log in to reply