SOLVED - 2 questions about new pfSense installation (hostname and wifi related)



  • I installed pfSense and I'm loving it so far. I upgraded from a DD-WRT (wrt54gl) router because of OpenVPN and other features of pfSense.

    Before I upgraded, I had a wrt54gl router as the firewall, etc, and I had another wrt54g wireless router provide the wireless to my house. On the wireless router, I had a cable running from the switch of the wrt54gl to the switch of the wrt54g so that I could access my network from the wireless. I also had the wireless set up in the "Repeater" feature so that the wireless would only provide a wifi signal and direct any traffic to the wrt54gl. After I installed pfSense, I have it set up the same way, however, on my wireless router (wrt54g) no I have to set it up as an "AP" in order to get a signal. If I set it up in "Repeater" mode I don't get a wireless signal at all. The only thing that's changed is that I set up pfSense and changed the network address. What I'm thinking is happening is that once the wireless router is changed to "AP" mode it block broadcasts, and "Repeater" mode does not block broadcasts.

    Another issue that I am having is that before pfSense, I could connect to computers using the computer name (testmachine1) and now I can't connect using the computer name, instead I have to use the IP address.

    Does anyone have any ideas as to why these things are happening?

    I also posted it in the general area because I didn't really know what section it belongs to.

    Thank you all so much.



  • I suspect you replaced your WRT54-GL with pfsense?  This will simplify your life if you only have one firewall, and an AP for wireless.  You are correct that your WRT-54g needs to be in AP mode.  Leave it this way.

    In the pfSense webGUI enable DHCP (Services/DHCP).  Also enable Services/DNS Forwarder and tick the box that says 'Register DHCP leases in DNS forwarder'.  This should allow you to access your other machines by name just like the default Linksys setup.



  • You are correct, I replaced the wrt54gl with pfSense (so only one firewall on the network (pfSense)).

    So, I already had DHCP and DNS forwarding enabled, and I just enabled the "Register DHCP leases in DNS forwarder," however, the computer that I'm trying to access is actually set up with a static IP. I still like the "Register DHCP leases in DNS forwarder" option enabled and will leave it like that, but how would that work with the hostname of a static IP client?

    Thank you also for clearing up the wireless router question.



  • In Services -> DNS forwarder, below the first save button, add name entries for your systems with static IP addresses.



  • @wallabybob:

    In Services -> DNS forwarder, below the first save button, add name entries for your systems with static IP addresses.

    That seemed to work.

    Thank you!!!

    pfSense is great, and it is so versatile, and I'm still learning.

    Thank you all!!!


Log in to reply