Transparent mode for squid 2.5.14_2-p7.1 appears to be broken!!!!



  • With a fresh install of version 1.01, I installed squid 2.5.14_2-p7.1. As soon as I enable transparent mode squid stops. I tried this on two different machines. Pressing save several times does not help (that helped on some older versions).

    Rebooting does not work.

    Reinstalling does not fix this.

    Running  squid -k reconfigure from the shell results in:
    squid: ERROR: Could not send signal 1 to process 2409: (3) No such process

    I did not experience this problem with version 2.5.14_2-p7



  • Only the STOP code was changed (one line).  I seriously doubt that my changes caused this.  But why its not working I have no idea, I'll look into it but squid is getting to the point where I want to remove it and start over.



  • For me works no problems at all pfsense 1.0.1 latest squid package transparent mode ;)



  • I was about to post this last night but stayed up late playing with it instead.  No luck, same issues here.  It was working up until the latest version.



  • Sullrich,

    I hope you do not remove Squid.

    Version 2.5.14_2-p7 works in transparent mode. I have it running is several places and it works great, even with some access control options I added. (My additions didn’t make it into the new version, just incase your wondering if that is what broke squid.)

    Since Phusho’s install works, I will re-download 1.01 and try another fresh install. The 1.01 iso was the only thing in common with the two PCs I loaded.

    You folks are doing great work!!!



  • I second that, Squid brings some great features to the table.



  • Looks like there are actually three change to the squid.sh. stop area

    squid –k shutdown &          & added  so that is back-grounded

    killall -9  added to the other kills

    and

    sleep 15

    When I make a change and save it, in the GUI, I noticed multiple squid stop processes for about 15 seconds, while doing (ps waux | grep squid) from the command line.

    I commented out the sleep 15 (#sleep 15) in squid.sh and now squid is working.  :)
    On the surface, it looks like a  timing problem.



  • Commenting out the sleep function does nothing other than not sleep for 15 seconds.



  • I dunno why.

    This is a fresh 1.01 install.  WAN is DHCP, LAN is 192.168.1.1, the dHCP server is running, and I have SSH enabled. Squid is the only package added. Transparent proxy is on and I have a couple of websites black listed for testing.

    With the sleep 15 commented out squid works on boot up, restart and stop/start.

    ps waux shows:

    ps waux | grep squid
    root    1327  0.0  0.9  4400  2392  ??  INs  3:36PM  0:00.00 /usr/local/sbin/squid -D
    proxy  1330  0.0  2.8  8556  7108  ??  RN    3:36PM  0:23.47 (squid) -D (squid)
    root  13588  0.0  0.1  348  228  p0  R+    7:06PM  0:00.00 grep squid

    With sleep 15 uncommented, it will not start at boot up. Making a change to squid in the gui followed by a quick ps waux, shows the following results (within ~fifteen seconds of hitting the GUI save button):

    ps waux | grep squid
    root    3244  0.0  0.5  1644  1236  ??  S    7:54PM  0:00.01 /bin/sh /usr/local/etc/rc.d/squid.sh stop
    root    3257  0.0  0.5  1644  1236  ??  S    7:54PM  0:00.01 /bin/sh /usr/local/etc/rc.d/squid.sh stop
    root    3288  0.0  0.9  4400  2392  ??  Ss    7:54PM  0:00.00 /usr/local/sbin/squid -D
    proxy  3290  0.0  2.7  8388  6892  ??  S    7:54PM  0:00.13 (squid) -D (squid)
    root    3408  0.0  0.1  348  228  p0  R+    7:54PM  0:00.00 grep squid

    Then it dies………

    Is it OK that squid is running while “squid.sh stop” is running???

    I usually do not submit findings I can’t repeat. But, maybe this is useful information:

    Squid did start a couple of time with sleep 15 not commented out. Twice, I did a “find . –name squid.sh (couldn’t remember the path) and squid started. The same thing happened with opening squid.sh  with vi and closing it without making changes (could not repeat this).  One time when I added a new blacklisted URL  it started. I have not been able to repeat any of these thing more than twice.

    Keep in mind, if  I comment out sleep 15, squid manually starts and restarts every time and after every reboot.

    This is my fifth new install and I'm going between two PCs to be sure I don't have a hardware problem.



  • I have removed the squid package.  I just don't have the time to keep chasing these obscure bugs with this package.



  • hi

    looks like squid is working on some pc's only, i have 4 pf boxes, upgraded to 1.01, only 1 server made it with squid, the other 3 couldn't restart with squid installed,

    just to help.

    oops, spoke too soon, i just had a power failure today, and the only ps box that was running ok, didn't make it too, so none is of the 1.01 ps boxes restarting with squid installed.


Locked