Telnet Timeout **SOLVED**



  • Hey,

    We are having an issue with pfsense and telnet.  Our telnet program is set to keep alive, but pfsense is timing it out when it sits idle for a few minutes.  Where is the setting in pfsense to where i can set it to not timeout?



  • Something does not sound right here.  If your telnet client is really doing keepalive, the state table entry should not be getting expired.



  • It is definitely the firewall.  We were having the same issue with our sonicwall, but we were able to set the timeout and fix it.  Any ideas?



  • If a totally different firewall was having the same issue, I'd argue the contrary - that you have NOT fixed the telnet client to do keep-alive.  Why are you so sure you did?  Having to do anything in the firewall to avoid telnet sessions timing out tells me the telnet client is not doing keepalive after all.



  • danswartz,

    Here is a screenshot of the telnet set to keep alive.  Do you have any ideas on what setting in pfsense i could set to make it not shut off?




  • that isn't an idle keepalive - it is NOT turning on telnet idle timeout, which causes telnet to tear down the connection if idle for more than that period - zero in this case disables that.  tcp keepalive is not disabled, but the default there is like 2 hours so that won't help you.  seems like that client does not have a keepalive setting.  you can set the pfsense firewall to conservative mode, which will not kill idle connections (AFAIK).  Under 2.0 this is on System => Advanced => Firewall/NAT.  If you are on 1.2.3, I don't know - you might have to explore the GUI and see.



  • Hey,

    This fixed the issue.  I appreciate the help.  I am closing this thread.


Log in to reply